300D - No Glow! - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 03-06-2007, 10:59 AM Thread Starter
BenzWorld Junior Member
Date registered: May 2006
Vehicle: 76' 300D
Location: Houston
Posts: 24
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
300D - No Glow!

Hey Folks,
My 76' 300D's glo-indicator's been not always working the past few days. Sometimes would glo (indicating warming up the g-plugs), but usually wouldn't when the engine was already warm.
However - if I just went ahead and turned the start key (when glo-indicator was not on), I noted that the glo-indicator lighted up whilst truning the engine over, and given just about 10 seconds, the engine would fire-up.
I would get some definate smoke, but I've been getting some of that for 3 months now, of course suspecting that a g-plug or two is farting out on me.
Well, yesterday I figured to just get 5-new g-plugs and pulled #1 g-plug (closest to the rad.) to get #'s, and purchase the correct plugs. But! When I put it back in and went to start the engine - noo glo and nooo go! Even cranking it for 15 seconds or so (I'm in Houston - the temp was about 62 degrees at the time).
So... Anyone got an idea as to what the heckk happened? I'm about to ride my bicycle to the parts store to get my 5 new plugs (it's close). But! IS it just going to have a "no-glo" anyways? Why did it work before pulling #1, and not work when it's put back exactly as it was, pre-pull... Thanks - Dale
Psalm31:15 is offline  
Sponsored Links
post #2 of 3 (permalink) Old 03-12-2007, 10:49 PM Thread Starter
BenzWorld Junior Member
Date registered: May 2006
Vehicle: 76' 300D
Location: Houston
Posts: 24
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Cool 5-new g-plugs

For those facing similar problems; I replaced all 5 g-plugs and still have the same problem of no-glo when the engine's warm (or the outside temp's warm). They will glow as and when I "hit the key," (as before). Given about 10-15 seconds of this, the engine will fire up pretty well. Of course there's smoke, but not as much, showing that I definately had a dead g-plug or two.
When changing the g-plugs I found the threads & g-plug bores to be "gummy" & surprisingly dirty. I used about half a can of WD-40 spraying them each out about three seperate times. And they needed it! Before putting the new g-plugs in, I also turned the engine over for about a 7 second burst so as to push out any "overspray" of D-40. I did this in case too much fluid might be left inside an individual cylinder, potentially causing the head gasket to blow, or worse.
Looks like I'm going to have to take it to Helmut Holder Motors to get it diagnosed and fixed... Dale
Psalm31:15 is offline  
post #3 of 3 (permalink) Old 03-15-2007, 08:26 AM
BenzWorld Member
HITWTOM's Avatar
Date registered: Jan 2007
Vehicle: 1985 300CD, '85 500SEC, '97 SL320, '08 CLK350 Cabriolet
Location: Maryland (Washington DC area)
Posts: 230
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
HITWTOM is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    300D glow plugs changed - is there a better way? no-blue-screen W123 E,CE,D,CD,TD,TE Class 18 08-01-2016 11:08 PM
    Where is the glow plug relay on a 77' 300D??? Bev W123 E,CE,D,CD,TD,TE Class 4 12-03-2014 08:39 PM
    broken glow plugs in the cylinder 81 300d elgatoensombrero W123 E,CE,D,CD,TD,TE Class 29 07-07-2010 06:58 AM
    85 300d glow plug please help roempty General Mercedes-Benz 1 11-23-2004 10:29 AM
    Any One Have A Glow Plug Relay For Sale?? 83 300d panamacolin W123 E,CE,D,CD,TD,TE Class 0 08-23-2004 09:00 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome