ICU/Tach wiring after Pertronix conversion - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 12-02-2006, 09:16 PM Thread Starter
BenzWorld Member
 
Captain Scott's Avatar
 
Date registered: Apr 2005
Vehicle: 1974 450 SL
Location: Coos Bay Oregon
Posts: 55
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Question ICU/Tach wiring after Pertronix conversion

I'm not sure how to wire the Ignition Control Unit after putting in the Pertronix kit? I know it isn't needed, but without certain connections, the tach does not get its signal.

She runs great now, but without ICU being in the loop, I have no tach.

I have seen posts on folks who have successfully made this conversion, but there has been no mention of having to give up their tach. So I assume they have figured out how to wire it up.

Does anyone here know how?
Captain Scott is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 12-03-2006, 09:21 AM
BenzWorld Elite
 
Djenka018's Avatar
 
Date registered: Jan 2005
Vehicle: '80 450SLC Afro RHD Ikonengold
Location: ɹǝpu∩ uʍop 'ʎǝupʎS
Posts: 2,473
Mentioned: 0 Post(s)
Quoted: 65 Post(s)
Donno for sure but in general if you leave all the connections of original EFI other than those that supply injectors, your revs should work again. Rev metre reads pulses from ignition distributor (or say TDC sensor) and converts it into revs.
Must consult installer of petronix what can you reconnect of old EFI without interferrence.

.
Vitamin C for SL... the SLC
Djenka018 is online now  
post #3 of 3 (permalink) Old 12-19-2006, 11:55 AM Thread Starter
BenzWorld Member
 
Captain Scott's Avatar
 
Date registered: Apr 2005
Vehicle: 1974 450 SL
Location: Coos Bay Oregon
Posts: 55
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
FIxed!

Well, after connecting the wires per the third Pert tech support guy (black to the green tach wire from the ICU and the red to 12v+), it works fine! Tach and all. While I thought I had originally tried it that way, I must have been mistaken. Too bad this isn't the first time it's gone this way...
Captain Scott is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
85 300D (California) Tach wiring tbakphi22 W123 E,CE,D,CD,TD,TE Class 0 06-16-2006 11:42 AM
OEM CD/radio conversion wiring harness aucaster W126 S,SE,SEC,SEL,SD,SDL Class 1 04-17-2006 01:54 PM
xenon conversion for a 2000 ml help - wiring harness help. boomie W163 M-Class 3 01-09-2006 12:01 PM
Wiring tach and outside temp..... (pics working) MiguelXJ W124 E,CE,D,TD Class 0 12-14-2005 03:23 AM
Pertronix michael l Unimog 1 07-03-2004 08:47 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome