108 Wiring Harness needed - Page 2 - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #11 of 14 (permalink) Old 01-09-2014, 02:05 AM
BenzWorld Senior Member
 
MCMLXIX's Avatar
 
Date registered: Dec 2013
Vehicle: 2006 S65 AMG V12 Biturbo
Location: Las Vegas, NV USA
Posts: 450
Mentioned: 0 Post(s)
Quoted: 87 Post(s)
Garage
Quote:
Originally Posted by 6punkt3 View Post
since you brought this up.

I remember a friend in Germany in the early eighties he had trouble with that harness on a 300 SEL 3.5
Mercedes quoted an exorbitant amount of money back then, 30 years ago.

So what seems to be the problem with your wiring ?
It seems all V8s with that D-jetronic would have the same problem from ongoing engine heat exposure ?
And aren't the connectors fried then as well ?
Most of it seems to be brittle. There are a few breaks in the insulation at the bends. Someone damaged some of the connectors for sesnors. And most of the relay bases are cracked and have come off the mounts. I can get new injector pigtails and make my own section for that, but I would feel better with a complete new harness with original colors....

Here is what I'm working with....


---------------------------------------------------
Rich
2006 S65 AMG 1 of 427 in North America {For Sale}
1986 560SEL {FOR SALE}
MCMLXIX is offline  
Sponsored Links
Advertisement
 
post #12 of 14 (permalink) Old 01-09-2014, 03:22 AM Thread Starter
BenzWorld Elite
 
Grubeguy's Avatar
 
Date registered: Jan 2006
Vehicle: 73 280SE 4.5, 71 300SEL, 03 BMW Z4, 72 Fiat 850, 80 Triumph TR7, 85 Porsche 911
Location: DC Area
Posts: 2,111
Mentioned: 1 Post(s)
Quoted: 97 Post(s)
Send a message via MSN to Grubeguy Send a message via Yahoo to Grubeguy
(Thread Starter)
Wow, memories... my original issue was a car sometimes not starting and sometimes just dying altogether. I tried making my own harness and labeling them with printed labels but I gooned it up and ended up buying a used one from a junk yard. It still works. Even that harness though is brittle. The connectors seem to be unphased however.

If you're replacing it just to replace it, reconsider. Ifyou have an issue, find the bad wire and replace just that... you'll thank me later
Grubeguy is offline  
post #13 of 14 (permalink) Old 01-14-2014, 04:03 PM
BenzWorld Senior Member
 
MCMLXIX's Avatar
 
Date registered: Dec 2013
Vehicle: 2006 S65 AMG V12 Biturbo
Location: Las Vegas, NV USA
Posts: 450
Mentioned: 0 Post(s)
Quoted: 87 Post(s)
Garage
I think I'm going to try and just replace the bad wires to get the car running. Rhode Island wire offers the correct colors and styles needed from 18 gauge down to 6 gauge... They have color charts on the website, I just need to make a list of what I need....

---------------------------------------------------
Rich
2006 S65 AMG 1 of 427 in North America {For Sale}
1986 560SEL {FOR SALE}
MCMLXIX is offline  
post #14 of 14 (permalink) Old 01-14-2014, 04:24 PM Thread Starter
BenzWorld Elite
 
Grubeguy's Avatar
 
Date registered: Jan 2006
Vehicle: 73 280SE 4.5, 71 300SEL, 03 BMW Z4, 72 Fiat 850, 80 Triumph TR7, 85 Porsche 911
Location: DC Area
Posts: 2,111
Mentioned: 1 Post(s)
Quoted: 97 Post(s)
Send a message via MSN to Grubeguy Send a message via Yahoo to Grubeguy
(Thread Starter)
I'm not sure if it was mentioned previously in this thread, but there's a wiring diagram posted in the online resources portion of the forum...
Grubeguy is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    1993 600SEL body harness vs. wiring harness Sojourner43 W140 S-Class 6 09-17-2007 11:34 PM
    Wiring Harness kcb W140 S-Class 20 09-24-2006 09:27 AM
    1997 W210 Wiring Harness needed VeneBenz W210 E-Class 0 05-10-2004 11:43 AM
    wiring harness Guest (MBNZ) W124 E,CE,D,TD Class 5 06-26-2002 09:06 AM
    Wiring Harness Guest (MBNZ) W124 E,CE,D,TD Class 0 10-19-2001 07:18 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome