78 300CD - Preglowing - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 10-10-2006, 09:04 AM Thread Starter
BenzWorld Newbie
 
Date registered: Oct 2006
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
78 300CD - Preglowing

Hi All -
I have a 1978 300CD and I'm experiencing some issues with preglowing. When I insert the key and turn it to the right into the position where the preglowing light would normally come on, nothing happens. This is normal if the car has been running for a bit and no preglowing is necessary, however the vehicle has been parked since last night and hasn't been run since then.

Anyone have any insight as to what could be done to remedy this? I checked the fuse box and replaced the only fuse that was bad, this didn't make a difference, plus the owner's manual didn't indicate that any of the fuses had control over the preglowing.

Thanks in advance!
bornwthatail is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 10-10-2006, 09:49 AM
Administratoris Emeritus
 
GeeS's Avatar
 
Date registered: Aug 2002
Vehicle: 2021 SL770
Location: Fountain Hills, AZ
Posts: 45,218
Mentioned: 2 Post(s)
Quoted: 751 Post(s)
Could be a bad pre-glow relay.

"If spending money you don't have is the height of stupidity, borrowing money to give it away is the height of insanity." -- anon
GeeS is offline  
post #3 of 7 (permalink) Old 10-10-2006, 12:27 PM Thread Starter
BenzWorld Newbie
 
Date registered: Oct 2006
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Update: I called a recommended M-B mechanic in the area and he had me checxk the fuse that powers the glow plugd and relay system. Sure enough, it was shot. I'm going to replace it now and if this dosen't resolve the problem I'll seek further help.
bornwthatail is offline  
 
post #4 of 7 (permalink) Old 10-10-2006, 01:02 PM
Administratoris Emeritus
 
GeeS's Avatar
 
Date registered: Aug 2002
Vehicle: 2021 SL770
Location: Fountain Hills, AZ
Posts: 45,218
Mentioned: 2 Post(s)
Quoted: 751 Post(s)
Wow -- that's good news!

"If spending money you don't have is the height of stupidity, borrowing money to give it away is the height of insanity." -- anon
GeeS is offline  
post #5 of 7 (permalink) Old 10-10-2006, 11:58 PM Thread Starter
BenzWorld Newbie
 
Date registered: Oct 2006
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
That did it. One $3 part later and she's up and running again.
bornwthatail is offline  
post #6 of 7 (permalink) Old 11-02-2007, 09:11 AM
BenzWorld Junior Member
 
Date registered: Nov 2007
Posts: 32
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
which fuse is that and where do i find it? i am having the exact same problem with my 79 240d
for now i have hooked up a remote starter with the switch in the cab and the wires run to the battery and the preglow control under the hood, when i pull the starter switch the plugs fire up and 10 - 30 seconds later i am ready to start the car. this works every time, but the wierd thing is i dont need it every time, every once in a while the preglow light comes on and it works perfectly. but most times i have to turn them on manually. any thoughts on this.
sorry to jump in to this thread but it seems your problem has been resolved and i am having the same issue. so thanks for any help!
kingdaddy is offline  
post #7 of 7 (permalink) Old 11-02-2007, 05:46 PM
BenzWorld Elite
 
diametricalbenz's Avatar
 
Date registered: Oct 2005
Vehicle: '77 6.9, 74 240D, 96 Ram 5.9L Cummins, 02 Civic EX, 10 Mazda 5 Sport
Location: Atlanta, GA
Posts: 2,652
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
Quote:
Originally Posted by bornwthatail View Post
That did it. One $3 part later and she's up and running again.
Was the strip fuse blown or just corroded?

1977 - W116 - 6.9
1974 - W115 - 240D /8 - 4(M) OM617.910 + Turbo + 300D FW - Completed 7/8/10
diametricalbenz is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
300cd curlycarille W123 E,CE,D,CD,TD,TE Class 1 03-26-2006 11:59 PM
Value of a 300CD Autobahnfahrer W123 E,CE,D,CD,TD,TE Class 9 11-06-2005 09:53 PM
value of '85 300cd stro908 W123 E,CE,D,CD,TD,TE Class 5 10-09-2004 09:01 PM
300CD value Guest (MBNZ) W123 E,CE,D,CD,TD,TE Class 6 05-23-2002 01:34 AM
Hello and 300CD Help... Guest (MBNZ) W123 E,CE,D,CD,TD,TE Class 3 04-06-2002 10:11 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome