'76 450 sl won't stay running - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 06-27-2006, 07:04 AM Thread Starter
BenzWorld Junior Member
squirrel_master's Avatar
Date registered: Jun 2006
Posts: 13
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
'76 450 sl won't stay running

I have also posted this on the 107 section...mods, please don't pull this!

I recently acquired a '76 450sl that has been sitting for a couple of years. I drained all the old gas out, blew out the lines, and put in fresh fuel. The car will start right up and run for a few minutes, but as soon as the engine starts to get warm it wants to die. I have about 90 pounds of fuel pressure coming into the distributor. I have not yet checked the control pressure and I am working on building an adapter so I can. I can tell you all of the injectors seem to flow well, and the piston in the fuel distributor moves freely. After 5 minutes or so of running, the engine won't take any throttle. It will idle roughly and eventually die. It will start right back up, but wants to die right away. Any thoughts on this one?
squirrel_master is offline  
Sponsored Links
post #2 of 5 (permalink) Old 07-02-2006, 06:57 AM
BenzWorld Veteran
Date registered: Jun 2004
Posts: 700
Mentioned: 1 Post(s)
Quoted: 5 Post(s)
you must have a guage to test the pumps pressure,so what it is the pressure on the return side?
Have you checked the igniton.Could be fualty coil too.
mercmad6.3 is offline  
post #3 of 5 (permalink) Old 09-08-2012, 11:56 AM
BenzWorld Newbie
Date registered: Sep 2012
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
i have the same problem with my 77 450sl, it sat for 4 yrs, drained the gas, changed the fuel pump and filter, changed plugs, changed the fuel pressure valve, cold start works, when I bleed the line to the fuel distibutor, it seems to run good for a while, than dies.
casamont450sl is offline  
post #4 of 5 (permalink) Old 09-08-2012, 06:46 PM
BenzWorld Newbie
Date registered: Sep 2012
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
you may have a vacume problem, first change your fuel filter, than on your fuel pressure valve remove air hose on bottom, if it dies your ok, if not find your leak.
casamont450sl is offline  
post #5 of 5 (permalink) Old 09-16-2012, 06:44 PM
Lifetime Premium Member
Date registered: Sep 2008
Vehicle: 1975 450SL
Location: Phoenix
Posts: 2,432
Mentioned: 2 Post(s)
Quoted: 15 Post(s)
Lifetime Premium Member
Go over to the 107 forum here: R/C107 SL/SLC Class - Benzworld.org - Mercedes-Benz Discussion Forum . Read the sticky topic labelled Encyclopedia Germanica v107. There is a LOT of info there that may help you out. Pay attention to the info on K-Jet injection systems.


Remember: It's not just a car. It's an Adventure.
RadioTek is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome