w115 odometer stopped working - Page 2 - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #11 of 11 (permalink) Old 05-25-2006, 11:42 AM
BenzWorld Junior Member
mjlehner's Avatar
Date registered: Apr 2005
Vehicle: 1972 220D 4 spd man
Location: Cedar Rapids, Iowa
Posts: 12
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
The cluster on the 220 (w115) is held in by a jam gasket. Not sure what the right word is for it but it's a gray piece of vinyl/rubber that encircles the two large guages and literally just jams them in. Nothing else holds them in place except for the wires, etc. from behind. You can work the cluster loose, turn it sideways and disconnect what you need to in order to remove it. To replace, you just fit the jam gasket around the cluster and "jam it in" to where it's solid. Be sure to re-connect everything first and that's about it. Check your dash lights dimmer knob as well, prior to dis-assembly. If your dash lights dim nicely and brighten back up at the turn of the knob, no worries. But mine was flickering and/or not working. There is a potentiometer back there that you can clean up while you are in there.

They don't make anything like they used to. In fact, they never did.
mjlehner is offline  
Sponsored Links
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome