Final (hopefully) question on Idle/run issues w/ '73 280SE 4.5 - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 01-31-2006, 09:13 PM Thread Starter
BenzWorld Elite
 
Grubeguy's Avatar
 
Date registered: Jan 2006
Vehicle: 73 280SE 4.5, 71 300SEL, 03 BMW Z4, 72 Fiat 850, 80 Triumph TR7, 85 Porsche 911
Location: DC Area
Posts: 2,109
Mentioned: 1 Post(s)
Quoted: 95 Post(s)
Send a message via MSN to Grubeguy Send a message via Yahoo to Grubeguy
(Thread Starter)
Final (hopefully) question on Idle/run issues w/ '73 280SE 4.5

So, I'v ereplaced plugs, wires, fuel pump and filter, fuel trigger points, installed a Pertronix unit and coil, thermostatic time valve, air and fuel temp sensors, and set the timing. The car runs like a dream, except for one small oddity:

At times, two cylinders just ... drop out. The remaining 6 still run fine, but the engine bogs down a bit. It's still relatively smooth on 6, but there's an obvious power loss.

Additionally, my cold start circuit isn't energizing. I've replaced the injector, the relay and checked all the connections from the starter, forward.

Any advice from the experts? Could I have a bad ECU?

Thanks in advance - I've had lots of help from other members!

-Chris Steingrube (Grubeguy)
Grubeguy is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 01-31-2006, 09:16 PM
Administratoris Emeritus
 
GeeS's Avatar
 
Date registered: Aug 2002
Vehicle: 2021 SL770
Location: Fountain Hills, AZ
Posts: 44,915
Mentioned: 2 Post(s)
Quoted: 591 Post(s)
RE: Final (hopefully) question on Idle/run issues w/ '73 280SE 4.5

The thermo-time switch controls the cold start valve. I would check that first.

"If spending money you don't have is the height of stupidity, borrowing money to give it away is the height of insanity." -- anon
GeeS is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome