w108 distributor has oil in it !! - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 11-29-2005, 06:58 PM Thread Starter
BenzWorld Newbie
Date registered: Nov 2005
Vehicle: 1972 280se 4.5L
Location: McAllen TEXAS
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
w108 distributor has oil in it !!

Hello , I have a 1972 280se 4.5 that was running very well until just recently.
I have been over this engine thoughroly in the last yr. New plugs,points,coil, intake gaskets and I also removed the distributor and cleaned it up along with the trigger points.
All was going well until recently some oil vapor came in thru the distributor (shaft?) and fouls the points making it miss and backfire.
Can you rebuild a distributor or get a factory rebuilt one with fresh seals and so forth?
Do you all have any ideas or fixes? Besides this it runs like a bat-outta-the-fatherland!!
I also replaced the thottle position switch on the throttle body. I am not sure if the is a proper placement of this I just placed it back in the most 'neutral' position .
Thanks for any help. Mitch

" To faith and virtue we make promises , fear and pain we obey."
MLADYMAN is offline  
Sponsored Links
post #2 of 2 (permalink) Old 12-04-2005, 02:34 AM
BenzWorld Newbie
Date registered: Aug 2004
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: w108 distributor has oil in it !!


My 1973 350 SLC (similar V8engine)also has a similar problem with the trigger points in the distributor becoming fouled. The engine runs like a dog progressively improving over about 20 mins of running - at the end of the journey she'll be purring like a cat. Its frustrating to know that each journey will begin like this - I think maybe if I drove it more often it wouldnt be as bad. I have a spare distributor and can see a rubber seal at the base of the shaft an inch or so above the gear teeth. Theres no obvious way to replace this easily. Anyone else any ideas?

Pete Moreau
Kildare, Ireland
Kildare_SLC is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome