I found a 280 SE Coupe! - Page 2 - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #11 of 16 (permalink) Old 07-16-2004, 12:09 PM Thread Starter
BenzWorld Elite
 
Date registered: Aug 2002
Vehicle: 2004 E55-1970 280SEC
Location: Houston, Texas USA
Posts: 2,026
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
RE: Ended up not getting the car, but got this one instead....

I definitely would go with the 95. It needs it, when it was designed gas was 100.

2009 C63 AMG Silver/Charcoal
1970 280SE Low Grill Coupe 2.8 Silver/Red


Past
1999 SLK230/Sport
2001 SLK32 AMG
2004 E55 AMG
Norb is offline  
Sponsored Links
Advertisement
 
post #12 of 16 (permalink) Old 07-16-2004, 05:51 PM
BenzWorld Member
 
Date registered: Feb 2004
Posts: 69
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: I found a 280 SE Coupe!

Do you even need the lead additive? Aren't the valves in these engines stainless (meaning they don't need the unleaded fuel)?
pv0463 is offline  
post #13 of 16 (permalink) Old 07-16-2004, 07:08 PM Thread Starter
BenzWorld Elite
 
Date registered: Aug 2002
Vehicle: 2004 E55-1970 280SEC
Location: Houston, Texas USA
Posts: 2,026
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
RE: I found a 280 SE Coupe!

That's why I haven't used it. The valves are hardened on my model already, but what would it hurt?

2009 C63 AMG Silver/Charcoal
1970 280SE Low Grill Coupe 2.8 Silver/Red


Past
1999 SLK230/Sport
2001 SLK32 AMG
2004 E55 AMG
Norb is offline  
 
post #14 of 16 (permalink) Old 07-16-2004, 08:23 PM
BenzWorld Member
 
Date registered: Feb 2004
Posts: 69
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: I found a 280 SE Coupe!

I just wouldn't use lead unless absolutely necessary...something about a cleaner, lead-free fuel makes me sleep easier at night; cleaner environment and all...
pv0463 is offline  
post #15 of 16 (permalink) Old 07-16-2004, 10:12 PM
BenzWorld Junior Member
 
Date registered: Jul 2004
Vehicle: '67 300SE coupe
Location: Australia!
Posts: 18
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via MSN to mercnmini
RE: I found a 280 SE Coupe!

Over here in australia we have 95 and 98 i think.. we use the 98 in our 300SE coupe and put this other stuff in the fuel.. not quite sure what it is though.
mercnmini is offline  
post #16 of 16 (permalink) Old 07-17-2004, 08:30 AM Thread Starter
BenzWorld Elite
 
Date registered: Aug 2002
Vehicle: 2004 E55-1970 280SEC
Location: Houston, Texas USA
Posts: 2,026
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
RE: I found a 280 SE Coupe!

It doesn't have lead, its a lead substitute.

2009 C63 AMG Silver/Charcoal
1970 280SE Low Grill Coupe 2.8 Silver/Red


Past
1999 SLK230/Sport
2001 SLK32 AMG
2004 E55 AMG
Norb is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome