1967 230SL - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 05-01-2004, 10:09 PM Thread Starter
BenzWorld Member
 
Date registered: Apr 2003
Vehicle: 95 E320
Location: UK
Posts: 242
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1967 230SL

were are the jacking points on this car, and where does one place the stands to hold the car up in the front? i can get pictures if needed,

also oil plug location, and what kind of oil should i put in to get the car started back up... thae car has been sitting for about 4 years no but did have a major service with most hoses and breaks replaced a while before it began sitting....
Attached Images
File Type: jpg 24_1223325_522004121337AM.jpg (22.1 KB, 141 views)
File Type: jpg 24_1223325_522004121517AM.JPG (33.5 KB, 148 views)

95' E 320-current ride
94' E500(Gone)
88' 300SEL(Gone)
SethMac86 is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 05-01-2004, 10:17 PM Thread Starter
BenzWorld Member
 
Date registered: Apr 2003
Vehicle: 95 E320
Location: UK
Posts: 242
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
RE: 1967 230SL

also car is a 5-speed, im thinking of posting an online restoration journal type thing here... those pics were takin 2 weeks ago and since then we have put a junk tire on the rear left tire, which was compleatly flat, and rolled it out and gave it a nice wash... ill post more pics tomorrow when we might change the oil and get the gas out in prep to change all the fluids to try and start it back up again....

95' E 320-current ride
94' E500(Gone)
88' 300SEL(Gone)
SethMac86 is offline  
post #3 of 12 (permalink) Old 05-02-2004, 12:57 PM Thread Starter
BenzWorld Member
 
Date registered: Apr 2003
Vehicle: 95 E320
Location: UK
Posts: 242
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
RE: 1967 230SL

here are the pictures of the under side of the front of the car, the red arrow points to the place where i think one would jack up the car, and the blue arrows point to where i think the stands would go...can anybody help?...

1st pic is front right
2nd is front right
3rd front left
Attached Images
File Type: jpg 24_1223505_52200425823PM.JPG (38.8 KB, 140 views)
File Type: jpg 24_1223505_52200425851PM.JPG (36.5 KB, 142 views)
File Type: jpg 24_1223505_52200425911PM.JPG (33.7 KB, 108 views)

95' E 320-current ride
94' E500(Gone)
88' 300SEL(Gone)
SethMac86 is offline  
post #4 of 12 (permalink) Old 05-02-2004, 01:00 PM Thread Starter
BenzWorld Member
 
Date registered: Apr 2003
Vehicle: 95 E320
Location: UK
Posts: 242
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
RE: 1967 230SL

pics
Attached Images
File Type: jpg 24_1223508_52200430037PM.JPG (38.8 KB, 101 views)
File Type: jpg 24_1223508_52200430059PM.JPG (36.5 KB, 86 views)
File Type: jpg 24_1223508_52200430123PM.JPG (33.7 KB, 114 views)

95' E 320-current ride
94' E500(Gone)
88' 300SEL(Gone)
SethMac86 is offline  
post #5 of 12 (permalink) Old 05-03-2004, 04:56 PM Thread Starter
BenzWorld Member
 
Date registered: Apr 2003
Vehicle: 95 E320
Location: UK
Posts: 242
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
RE: 1967 230SL

ok well you can ignore the previous post, we just went out and bought some ramps so were good to go there...

and ive got some great pictures of the car after we rolled it out and washed it...

also look at the near perfect condition of the soft top!! only a few very small holes and it fit perfectly after sitting for so long...
Attached Images
File Type: jpg 24_1224043_53200465658PM.JPG (35.7 KB, 132 views)
File Type: jpg 24_1224043_53200465728PM.JPG (30.8 KB, 115 views)
File Type: jpg 24_1224043_53200465755PM.JPG (34.8 KB, 137 views)
File Type: jpg 24_1224043_53200465900PM.JPG (54.5 KB, 141 views)

95' E 320-current ride
94' E500(Gone)
88' 300SEL(Gone)
SethMac86 is offline  
post #6 of 12 (permalink) Old 05-03-2004, 05:13 PM Thread Starter
BenzWorld Member
 
Date registered: Apr 2003
Vehicle: 95 E320
Location: UK
Posts: 242
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
RE: 1967 230SL

also when we got under the car we found that part of the steering linkage was broken/snapped/torn whatever... i havent had a good chance to look at it but i noticed on some of the pics you can see the problem, so im putting pics of the problem with and without it circled...
Attached Images
File Type: jpg 24_1224053_53200471358PM.JPG (35.9 KB, 126 views)
File Type: jpg 24_1224053_53200471441PM.JPG (38.4 KB, 92 views)
File Type: jpg 24_1224053_53200471527PM.JPG (35.5 KB, 106 views)

95' E 320-current ride
94' E500(Gone)
88' 300SEL(Gone)
SethMac86 is offline  
post #7 of 12 (permalink) Old 05-03-2004, 05:19 PM Thread Starter
BenzWorld Member
 
Date registered: Apr 2003
Vehicle: 95 E320
Location: UK
Posts: 242
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
RE: 1967 230SL

also i am asking fellow members at ferrarichat.com for help so heres the link...

http://ferrarichat.com/forum/showthread.php?p=244463#post244463

thanks seth mac

95' E 320-current ride
94' E500(Gone)
88' 300SEL(Gone)
SethMac86 is offline  
post #8 of 12 (permalink) Old 05-03-2004, 08:05 PM
BenzWorld Junior Member
 
Date registered: Jul 2003
Vehicle: 1967 250SL
Location: Los Angeles
Posts: 28
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: 1967 230SL

Seth, the best thing you can do for your car is join the following online clubs devoted to the W113 chassis. Experts will supply all the answers and encourage you along the way toward a finished restoration. Good luck.

www.Pagoda113.com and www.SL113.org
TA250SL is offline  
post #9 of 12 (permalink) Old 05-04-2004, 08:01 AM
BenzWorld Elite
 
Date registered: Sep 2003
Vehicle: 111.010
Location: Chicago
Posts: 1,844
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: 1967 230SL

I think that is the center link or drag link that is broken. Pretty cheap part to source. Also check out wwww . mbz . org for a good forum on these older cars. There are several lists that would yield good info.

Search first, ask second!
mb230s is offline  
post #10 of 12 (permalink) Old 05-04-2004, 05:07 PM Thread Starter
BenzWorld Member
 
Date registered: Apr 2003
Vehicle: 95 E320
Location: UK
Posts: 242
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
RE: 1967 230SL

thanks i signed up for the 2nd forum you listed the first one has a $33 a year fee... so cant post there yet...

and about the thing hanging down... someone over at f-chat said i should just get one made, at a local shop, and what not, which would most likly be stronger and less likly to break, i think, but i'll still look up the prices

thanks
seth mac

95' E 320-current ride
94' E500(Gone)
88' 300SEL(Gone)
SethMac86 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome