Turbo Charging an SL - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 04-28-2003, 05:50 PM Thread Starter
BenzWorld Newbie
Date registered: Apr 2003
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Turbo Charging an SL

Has any one ever put or seen a turbo charger on a SL, I purchased a kit off of EBAY and I was wondering how well they work.
vloy is offline  
Sponsored Links
post #2 of 2 (permalink) Old 12-27-2003, 08:11 PM
BenzWorld Member
AnE2pleaz's Avatar
Date registered: Nov 2002
Vehicle: 89 300TE
Location: Beautiful Queensland, Australia
Posts: 290
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: Turbo Charging an SL

Which SL are you talking about?


1989 300TE Smoke Silver, Red MBTEX - 421,000kms (Sold and sadly missed)
1991 300TE Grey, light grey MBTEX - 348,000kms
1985 280SE White, tan MBTEX - 375,000kms
AnE2pleaz is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome