Vito 110CDI problem - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > V-Class
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-09-2009, 05:47 AM   #1 (permalink)
BenzWorld Newbie
 
Date registered: Sep 2009
Posts: 3
Vito 110CDI problem

Hi all, I've been here reading all the posts for a while now and have a problem that I can't find any information on that I hope someone can help with?

I have a 2000 110cdi and when I try and pull away with low revs, my van judders and it sounds like something in the engine bay is rattling really loudly. It happens whether the engine is warm or cold. It is also happens when I'm in to high a gear for my speed and try to accelerate. I've only had the van a couple of weeks and hope this isn't a terminal problem!

Hope someone can help.

Jamie
Jamie700 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-09-2009, 08:11 AM   #2 (permalink)
BenzWorld Junior Member
 
Date registered: Sep 2009
Posts: 30
Sounds like you need someone to rev the engine a little bit while your'e looking under the bonnet to see if you can hear/see whats rattling.
vito_birky is offline   Reply With Quote
Old 11-10-2009, 06:11 AM   #3 (permalink)
BenzWorld Member
 
jonny rash's Avatar
 
Date registered: May 2009
Vehicle: 2000 Vito 110CDI (never should have sold it), Current project 1999 V220 Ambient
Location: Honiton, Devon
Posts: 356
PLease give more information. Could be anything from a rogue tool left in the engine bay ( I found a copper mallet in the engine bay of a van once when I got it home from buying it) to loose mounting bolts or knackered big end bearings.

Is there oil in the sump?
Has the oil been changed regularly? or at all?
Do you get a lot of smoke from the exhaust?
jonny rash is offline   Reply With Quote
Old 11-10-2009, 08:40 AM   #4 (permalink)
BenzWorld Newbie
 
Date registered: Sep 2009
Posts: 3
Right, I haven't had a look at the sump yet, I was hoping someome would have an amazing idea before I had to take it apart. From what I've checked the oil looks like it could do with being changed. The guy I got it from said it had been serviced regularly but didn't have anything to prove it. As for smoke from the exhaust there is a bit of black smoke when I accelerate hard but nothing more then you'd expect. I don't see the road disapear behind me.

The rattle itself tends to be worse when your on full lock, trying to sneak into a parking spot for instance. At motorway speed the vans fine, it runs quiter than I expected. Its just pulling away or reversing with low revs.

I'll have a look tommorrow when its light to see if I can see any tools floating around!

Cheers the help.
Jamie700 is offline   Reply With Quote
Old 11-10-2009, 02:45 PM   #5 (permalink)
BenzWorld Junior Member
 
Date registered: Oct 2009
Vehicle: mercedes vito 108
Location: north east
Posts: 28
Quote:
Originally Posted by Jamie700 View Post
Right, I haven't had a look at the sump yet, I was hoping someome would have an amazing idea before I had to take it apart. From what I've checked the oil looks like it could do with being changed. The guy I got it from said it had been serviced regularly but didn't have anything to prove it. As for smoke from the exhaust there is a bit of black smoke when I accelerate hard but nothing more then you'd expect. I don't see the road disapear behind me.

The rattle itself tends to be worse when your on full lock, trying to sneak into a parking spot for instance. At motorway speed the vans fine, it runs quiter than I expected. Its just pulling away or reversing with low revs.

I'll have a look tommorrow when its light to see if I can see any tools floating around!

Cheers the help.
sounds like one of your CV joint if its when you turn they are very common vitos, drive around with full lock on in a car park and see what side is making the noise
mercs47 is offline   Reply With Quote
Old 11-11-2009, 01:18 PM   #6 (permalink)
BenzWorld Newbie
 
Date registered: Nov 2009
Posts: 2
i have a daft weight on my gear linkage that rattles not sure what its for but does my head in might be that
p20cro115 is offline   Reply With Quote
Old 11-11-2009, 02:04 PM   #7 (permalink)
BenzWorld Member
 
Hodgy's Avatar
 
Date registered: Oct 2008
Vehicle: Vito 108cdi
Location: Leeds, England
Posts: 305
The weight thing on mine rattled against the suspension top, I removed it and put a thick washer under it to raise it above the suspension top, which stopped the rattle.

There seemes to be a nylon bush inside that had worn away on mine, I don't know if these are available seperately or if you have to buy the whole assembly
__________________


Hodgy is offline   Reply With Quote
Old 11-12-2009, 05:13 AM   #8 (permalink)
BenzWorld Newbie
 
Date registered: May 2007
Posts: 1
Hi, I think you may have a similar problem to what I had.
My engine had knocking and rattling noises at idle and on full lock was even louder. Like yours it was quiet when going along.

I feared that it was an engine internal problem but after researching around the internet(probably this site?) decided to buy a few choice parts to try and remedy the problem.

For me it was the belt tensioner and water pump bearing ( I think)
Because after changing these my engine rattles were ALMOST all gone.
I think for me theres still something in the same area with minor noise problems but its good enough for now.

So I'd suggest looking around the belt area for worn components (changing the belt while your down there might be a good idea).

Regards
Tony
Tontonly is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > V-Class

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Topic Author Forum Replies Last Post
problem wobbly handling vito 110cdi 2000 reg mick2a V-Class 7 10-20-2009 12:01 PM
vito 110cdi 2000 help please khan_uk0 V-Class 13 06-23-2009 05:41 PM
mercedes vito 110cdi speedo problem. cabdriver Audio & Telematics Forum 0 08-17-2008 04:55 PM
vito 110cdi stating problem andrewr2001 V-Class 0 03-09-2008 03:09 AM
Vito 108CDi & 110CDi ugly V-Class 3 11-22-2005 06:07 AM


All times are GMT -7. The time now is 06:48 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.