Immobilizer System Fault? - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 08-24-2006, 06:17 AM
BenzWorld Member
 
Date registered: Aug 2006
Vehicle: Vito 113, X-Trail
Location: Singapore
Posts: 174
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
(Thread Starter)
Immobilizer System Fault?

Hi, I am new to this forum and really love my 2000 Vito to death.

But I could really use the help of anyone who has a similar problem to mine and managed to solve it.

My Vito 113 cranks over a second or two when I start it. Then dies. Each time I start it, it'll crank over the same span of time, then die completely.

I think it's the immobilizer system and have located it behind the instrument cluster, but I have no way of detecting if it's the faulty party. I've tried both my keys - same effect.

1) Does an immobilizer fault show up on an OBD II reader
2) What is the code?
3) Has anyone replaced his unit and how much does it cost?
4) Do the keys need to be reprogrammed?

I'd bring it to the dealership - but the local one here is a complete ripoff!

So Im trying to fix this with the help of some of the experts here.

Thanks in advance!

leongster is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 08-25-2006, 08:46 AM
BenzWorld Member
 
Date registered: Aug 2006
Vehicle: Vito 113, X-Trail
Location: Singapore
Posts: 174
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
(Thread Starter)
Uhh, I finally got my immobilizer to work. Seems it was a contact problem with the wires on the unit. After a bit of jiggling it works fine now.
leongster is offline  
#3 (permalink) Old 08-27-2006, 10:46 AM
BenzWorld Extremist
 
adamuk's Avatar
 
Date registered: Apr 2006
Vehicle: Vito 111CDi 2004
Location: Middlesbrough
Posts: 1,109
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Welcome! There's not much expertise here (or if there is, it comes out very slowly..) The MB workshop manual is available on ebay (comes as 3 or 5 DVDs) and it's definitely helped me out of a few tight spots.

Cheers

Adam.
adamuk is offline  
#4 (permalink) Old 08-28-2006, 02:15 AM
BenzWorld Member
 
Date registered: Aug 2006
Vehicle: Vito 113, X-Trail
Location: Singapore
Posts: 174
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
(Thread Starter)
Quote:
Originally Posted by adamuk
Welcome! There's not much expertise here (or if there is, it comes out very slowly..) The MB workshop manual is available on ebay (comes as 3 or 5 DVDs) and it's definitely helped me out of a few tight spots.

Cheers

Adam.
Thanks for the lead. I got the manual by Russek, and it is a little basic. Will get the CDs.

Best,

Eddie
leongster is offline  
#5 (permalink) Old 09-25-2011, 02:09 PM
BenzWorld Newbie
 
Date registered: Sep 2011
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Hi im new can anyone help i have a v class Ambiente had it 2 weeks ,sometimes when indercating left or right the hazards lights come on i think its the immobiliser ,becouse theres a noise to the right of the dash thy work fine one day .it plays up more when its raining ,,changed battery in remote and had new van battery ..can someone help love my Ambiente thanks
welshman56 is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > V-Class

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
ML Tech Trivia: Immobilizer S4toML W163 M-Class 10 02-21-2011 08:37 AM
bought 1999 S reg s/a a class cant find immobilizer port 2 put my immobilizer key in Ali_c W168 A-Class 2 08-28-2005 01:01 PM
Immobilizer spit64 W124 E,CE,D,TD Class 1 07-30-2005 12:04 PM
Immobilizer Cmdr737 R129 SL Class 3 04-11-2005 11:53 AM
Clearing fault codes from the system ally_230ce W124 E,CE,D,TD Class 2 01-24-2005 02:28 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome