my vito engine cuts out, edc light on - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 08-14-2005, 04:42 PM
kab
BenzWorld Newbie
 
Date registered: Aug 2005
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
my vito engine cuts out, edc light on

hello - this is my first post and I hope you can help me. I have a UK Vito 110cdi registered in 2000, with 125000 recorded miles. On a few occasions recently the engine has cut out while I've been driving, and the EDC light has come on. If I turn off the ignition for about 10 seconds and restart the van the engine will start normally and the warning light is off. It then behaves as normal for several hundred miles before doing it again. This can be dangerous so I want to get it sorted out quickly. Any ideas before I take it to the mechanic? Thanks in advance.
kab is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 09-14-2007, 04:21 PM
BenzWorld Junior Member
 
Date registered: Jan 2007
Vehicle: vito 110CDi
Location: warrington
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Guest
hello - this is my first post and I hope you can help me. I have a UK Vito 110cdi registered in 2000, with 125000 recorded miles. On a few occasions recently the engine has cut out while I've been driving, and the EDC light has come on. If I turn off the ignition for about 10 seconds and restart the van the engine will start normally and the warning light is off. It then behaves as normal for several hundred miles before doing it again. This can be dangerous so I want to get it sorted out quickly. Any ideas before I take it to the mechanic? Thanks in advance.
i`ve got the same problem,any idea what it is yet?
bakersville is offline  
#3 (permalink) Old 09-15-2007, 11:47 AM
BenzWorld Junior Member
 
Date registered: Jul 2006
Location: BELFAST ire
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Hi Bakersville, you should have got my reply. Gerrry.
geeboy is offline  
#4 (permalink) Old 01-09-2008, 11:59 PM
BenzWorld Newbie
 
Date registered: Jan 2008
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Post Same fault - several possibilities

I just bought my first (and last vito) and it has same fault. It had fuel pump problem which I fixed by installing electric serial pump on fuel line, but it has also problem which previous owner(s) tried to fix. Everything works fine till engine will reach about 60C. Then EDI light comes on and dumb computer will stop the engine. To fix the problem previous owner removed thermostate, but that is not solution...-I believe there is either temperature sensor giving wrong information to computer or computer itself is faulty, thinking that engine is now overheating.
If anyone knows how to bypass this, please let me know!

PS. VITO is designed for idiots, so if you are not one, please get yourself some more reliable van which will let you to decide when to turn engine off...
jackhoover is offline  
#5 (permalink) Old 01-10-2008, 01:44 AM
BenzWorld Member
 
Date registered: Nov 2007
Vehicle: 2000 Vito 110cdi
Location: Lampeter, Wales
Posts: 65
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by jackhoover View Post
PS. VITO is designed for idiots
Well we're /all/ gonna help you now
joff is offline  
#6 (permalink) Old 01-10-2008, 02:06 AM
BenzWorld Member
 
stoneboy's Avatar
 
Date registered: Jun 2007
Vehicle: V280 LPG 2000
Location: Cardiff
Posts: 341
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by jackhoover View Post
PS. VITO is designed for idiots, so if you are not one, please get yourself some more reliable van which will let you to decide when to turn engine off...
Totally agree. I wish I had bought one of those vans that has never had a fault in all the years thay have been making them.
stoneboy is offline  
#7 (permalink) Old 01-10-2008, 04:47 AM
BenzWorld Member
 
Date registered: Aug 2006
Vehicle: Vito 112 CDi year:2001
Location: UK
Posts: 285
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by jackhoover View Post
PS. VITO is designed for idiots, so if you are not one, please get yourself some more reliable van
jackhoover, don't keep us idiots in suspense, tell us the make of this more reliable van! Model T ford?
4xpaws is offline  
#8 (permalink) Old 01-10-2008, 08:37 AM
BenzWorld Member
 
Date registered: Nov 2007
Vehicle: 2000 Vito 110cdi
Location: Lampeter, Wales
Posts: 65
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
shut up you bloody idiot, and stop repeating yourself

fpmsl
joff is offline  
#9 (permalink) Old 01-10-2008, 09:00 AM
BenzWorld Newbie
 
Date registered: Jan 2008
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Hi, I am new to the forum. I have a 1999 vito 108cdi and the EDC light is on, I wondered how to solve the problem, anybody any ideas? Thanks, Chris.
Shaw-T 111 is offline  
#10 (permalink) Old 01-15-2008, 10:56 AM
BenzWorld Newbie
 
Date registered: Jan 2008
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
same problem here too. Any ideas anyone?
pollyjohnson is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > V-Class

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome