WANTED: BabySmart Compatible Car Seat - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 04-12-2014, 10:38 AM Thread Starter
BenzWorld Junior Member
Date registered: Jan 2013
Vehicle: 2009 ML350; 2005 SLK350
Location: Binghamton, NY
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
WANTED: BabySmart Compatible Car Seat

I am looking for a BabySmart compatible car seat so as to deactivate the front seat passenger-side airbag in my 2005 SLK350. It is summer now and due to work things I have to take our child to daycare every day, which at the moment means I don't get to drive the SLK except on weekends (not cool). It would be great if the seat was one that was her size, but if not, I'll use the transponders in it on a different car seat we already have. Post or PM. Would pay with PayPal. Ship to 13903.
MrBobC is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > For Sale/Wanted/Trade/Giveaway

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome