fs - (4) W210 Chrome wheels 7.5x16 et41 - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 10-12-2013, 03:27 PM Thread Starter
BenzWorld Member
Date registered: Mar 2008
Vehicle: 1986 190E 2.3-16 euro, 1993 500E, 1995 E320W
Location: Orange County, CA
Posts: 125
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
fs - (4) W210 Chrome wheels 7.5x16 et41

Here is a set of (4) W210 chrome wheels 7.5x16 et41, no center caps

Part# A 210 401 06 02

I don't think they have ever been used, certainly not used after they have been chromed. They have a date 03/07/05 scribed on the barrel of the wheel which is probably the date when the wheels were chromed. All four are in excellent condition. like new, but one wheel has some minor surface pitting, see pictures

$400.00 fob socal, orange county

949-370-95n zero zero
captruff is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > For Sale/Wanted/Trade/Giveaway

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome