WTB: 10 pt sockets for OZ 3 piece rim bolts - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 11-09-2012, 06:31 PM Thread Starter
Lifetime Premium Member
 
magicbigdaddy's Avatar
 
Date registered: Dec 2006
Vehicle: 1989 560 SEC - V-8 Kompressor - 95 E320 Estate
Location: Everett, WA
Posts: 1,209
Mentioned: 0 Post(s)
Quoted: 141 Post(s)
Lifetime Premium Member
(Thread Starter)
WTB: 10 pt sockets for OZ 3 piece rim bolts

Just as the title says. I need a set of these sockets or a lead to where to buy them at a reasonable price. Thanks, Mike

1989 560 SEC Supercharged - 317+ rwhp - H&R lowered - OZ Nova's - upgraded brakes - AMG Tri-Y's - Bergwerks FGS - a true Euro Rod

1995 E420

1988 Euro 560SEL
magicbigdaddy is online now  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > For Sale/Wanted/Trade/Giveaway

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome