FS: 1995 W140 S600 Coupe in NY - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 12-12-2011, 07:41 AM Thread Starter
BenzWorld Member
rudelover2's Avatar
Date registered: Feb 2007
Vehicle: 1995 S600 Coupe * SOLD
Location: New York
Posts: 59
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
FS: 1995 W140 S600 Coupe in NY $4000

Lower Price - $4000

Sorry to have to leave all of the fun... but wifey wants a truck and is tired of lugging baby out of the back seat of the coupe. I was in the process of getting this thing together but, I wont be able to go any further.

Hit me at glenmosley at gmail dot com as I dont check here too often anymore.
Car is located in New York City. Clean Title is present

1995 S600 Coupe runs well ~175000 miles (odometer quit moving a year ago @161000) -
Silver with Navy blue interior - front seats are ok but have been repaired years ago before I owned the car
Front/rear bumper, driver fender and door need a little tlc
Engine runs smooth and strong. Problem is a crankcase oil leak that requires a quart of oil every 2 months
Transmission was rebuilt 2 years ago but flares on the 2-3 shift. I have been meaning to change the springs in the valve body. It works though
Needs wire harness - although numerous wire repairs were done to major components like airflow meters
Radio is pioneer with usb and aux input and all speakers work and sound great with factory bose amp
AC is cold - heat working
Numerous Control Arms and sway bar bushings/links replaced recently - rides pretty good, no rattles
New radiator, thermostat, hoses, serpentine belt and alternator within the last 3 months
Soft close works, seat belt extenders, moonroof work
Both headlights are recent from the dealer about 3 years old
Spark plugs and wires were done last year
Rear sunshade has difficulty operating. But functions
Driver seat only goes up and down, not forward and back. Maybe a motor is gone
Driver side mirror was knocked off by sanitation truck which also swiped the door and fender slightly. But it stays on and functions
Wipers work, headlight washers one moves and I have the motor for the other one
Power headrests all work properly
Needs a few bulbs on dash

1995 S600 Coupe

Last edited by rudelover2; 12-20-2011 at 11:08 AM. Reason: Lower price
rudelover2 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > For Sale/Wanted/Trade/Giveaway

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    1995 w140 S600 Coupe ASR limp problem - DTC codes the marshal General Mercedes-Benz 3 11-22-2012 02:46 PM
    Low Mileage 1995 W140 S600 Coupe...Full of Gremlins! Need Help Guys! caddykingaz W140 S-Class 23 02-10-2011 05:47 PM
    1995 S600 Coupe vs 2008 Bentley Continental GT Coupe Stryker-1999 S600 W140 S-Class 21 11-09-2010 10:25 AM
    About to buy a W140 1995 S600 coupe SteinwaySteve W140 S-Class 10 10-06-2010 06:59 PM
    1995 S600 Coupe... My Dream car! rb112278 General Mercedes-Benz 1 04-25-2010 06:04 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome