WTB working speedo/odo for 85 300sd - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-29-2008, 01:31 PM Thread Starter
BenzWorld Member
 
Date registered: Dec 2007
Vehicle: 1985 300SD California Spec
Location: Anaheim Hills, CA 92808
Posts: 75
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
WTB working speedo/odo for 85 300sd

Greetings, I am looking to buy a fully working (speedo and odo) speedo gauge for my 1985 300sd. The one in the car is a 126 542 81 01, 120mph speedo. Shoot me an email if you have a fully working unit for sale.
Attached Thumbnails
Click image for larger version

Name:	Speedo.jpg
Views:	55
Size:	177.7 KB
ID:	180559  

1985 300SD California spec
glovesave33 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 06-01-2008, 12:59 PM
BenzWorld Veteran
 
unbugai's Avatar
 
Date registered: Aug 2005
Vehicle: 1996 Mercedes-Benz S500
Location: Maine
Posts: 721
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
i got one chilling in the garage i think its around 260,000 miles tho but theyre easy to roll back.... last time i check it worked, so.... im also parting out my 300sd if you need any other parts pm me or whatever.
unbugai is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > For Sale/Wanted/Trade/Giveaway

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Speedo/odo question Northwinds W124 E,CE,D,TD Class 0 04-02-2008 01:22 PM
    a bazillion questions one at a time, odo lube - '84 300sd jedovaty W126 S,SE,SEC,SEL,SD,SDL Class 3 02-18-2008 02:29 AM
    Odometer stopped working, but speedo okay... canuckcarnut W140 S-Class 1 12-13-2007 04:32 PM
    I reset my trip meter and now the odo stopped working! vr6freak W124 E,CE,D,TD Class 4 10-06-2007 10:07 AM
    Speedo stopped working... jkinsey W123 E,CE,D,CD,TD,TE Class 7 07-20-2007 10:33 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome