WTB heater fan control - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 33 (permalink) Old 02-19-2008, 08:50 PM Thread Starter
BenzWorld Member
 
Date registered: Feb 2008
Vehicle: 1991 mercedes-benz 190e 2.6
Location: boise, id
Posts: 183
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via AIM to alp_2420 Send a message via Yahoo to alp_2420
(Thread Starter)
WTB heater fan control

so im lookin for a heater fan control for a 91 190e i just bought it as a little project and seems to me that the heater control likes to work when it wants to so im lookin for a used one so i dont have to pay alot of money..by the way im located in boise id so if someone on here is there with that part please let me know thanx
alp_2420 is offline  
Sponsored Links
Advertisement
 
post #2 of 33 (permalink) Old 02-19-2008, 08:59 PM
IR MODERATOR
 
Jippi's Avatar
 
Date registered: Aug 2002
Vehicle: 1996 Volvo 855GLT, 1993 MB 190e 2.3 8v, 1998 Subaru Outback SUS, 1991 BMW 525, 1998 MB C230
Location: somewhere in NJ or PA
Posts: 9,226
Mentioned: 1 Post(s)
Quoted: 3 Post(s)
Lifetime Premium Member
Send a message via AIM to Jippi Send a message via MSN to Jippi
contact rjb aka bob hes parting one


1993 MB 190E 2.3 105k- its alive.. 1996 Volvo 855 GLT-R 350k still rolling
1998 Subaru Outback SUS 210k- Daily Driver 2011 Toyota Camry XLE 36k
1991 BMW 525I stock as stock gets 98k (Wrecked) 1998 MB C230 209k possessed by the devil
Benzworld.org---Tri-State Crew

Last edited by Jippi; 02-19-2008 at 09:02 PM.
Jippi is offline  
post #3 of 33 (permalink) Old 02-19-2008, 09:16 PM
BenzWorld Member
 
HATTENATOR's Avatar
 
Date registered: Jan 2008
Vehicle: 1988 190E 2.3
Location: Missouri
Posts: 234
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Is it stopping intermitentily when you have your heat on and does it seem to run all the time when you have it set on the cold setting or a/c running. did you just notice it this winter. The reason I ask it may not be your fan, switch or relay give me more of a discription of the problem you are having

Why dream of just any vehicle, when you can dream of owning one that was never imported.
HATTENATOR is offline  
post #4 of 33 (permalink) Old 02-20-2008, 09:53 AM Thread Starter
BenzWorld Member
 
Date registered: Feb 2008
Vehicle: 1991 mercedes-benz 190e 2.6
Location: boise, id
Posts: 183
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via AIM to alp_2420 Send a message via Yahoo to alp_2420
(Thread Starter)
Quote:
Originally Posted by HATTENATOR View Post
Is it stopping intermitentily when you have your heat on and does it seem to run all the time when you have it set on the cold setting or a/c running. did you just notice it this winter. The reason I ask it may not be your fan, switch or relay give me more of a discription of the problem you are having

well i bought the car just recently and the guy said that the heater didnt work and he didnt want to take it into the shop blah blah blah so i figured i got the car for 1500 il deal with it myself and fix it my self just takes a little research. thats how i found this site..anyways i got a wild hair and took the center consol off and was like maby theres a bad connection (after i checked the fuses under the hood, wich were all fine, with good connections) so i was like ok ill check the connections on the back of the fan control and vent control yada yada yada and so im looking at it all and checking the connections and put everything back together and i just said F it im going back to work and when i comeback out to leave i turn the key and low and behold its blowing like a mother!!! and i got so excited and checked it all good A/C nice heat all that and then when i get out of work i get in the car to let it warm up and let the heater heat up and nothing no heater AGAIN so i pulled the fan control seeing thats what ive narrowed it down to and i took that apart and cleaned all the connections with rubbing alchohol and everything..and now im here typing this..sorry for itbeing so long too but thats the a-b on it
alp_2420 is offline  
post #5 of 33 (permalink) Old 02-20-2008, 05:25 PM
BenzWorld Member
 
HATTENATOR's Avatar
 
Date registered: Jan 2008
Vehicle: 1988 190E 2.3
Location: Missouri
Posts: 234
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
try this and see if your fan comes on before you replace the switch. On the right front frame rail next to the engine is a small pump it is the auxillary water pump for the heating system unplug it and see if your fan works now. When this is bad the cars are equipped with overlaod protection and it shuts the system down. It may not bee the problem but I like to try and help cover all bases before someone spends money on parts. I have a guide here that might also help http://www.benzworld.org/forums/w201...ol-system.html

Auxillary Water Pump

Why dream of just any vehicle, when you can dream of owning one that was never imported.

Last edited by HATTENATOR; 02-20-2008 at 05:27 PM.
HATTENATOR is offline  
post #6 of 33 (permalink) Old 02-20-2008, 08:56 PM Thread Starter
BenzWorld Member
 
Date registered: Feb 2008
Vehicle: 1991 mercedes-benz 190e 2.6
Location: boise, id
Posts: 183
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via AIM to alp_2420 Send a message via Yahoo to alp_2420
(Thread Starter)
man you are a god send!! i love the DIY stuff here..im guna try that first thing in the morning seeing its dark outside...i dunno if i said this befor but i noticed today when i was puttin the center console back when i push the vent select buttons i can hear the clicking in the fan switch part and i can hear the vents opening up and closing when i choose diff ones...anyways ill try this first thing in the morning thanx man
alp_2420 is offline  
post #7 of 33 (permalink) Old 02-20-2008, 09:15 PM
IR MODERATOR
 
Jippi's Avatar
 
Date registered: Aug 2002
Vehicle: 1996 Volvo 855GLT, 1993 MB 190e 2.3 8v, 1998 Subaru Outback SUS, 1991 BMW 525, 1998 MB C230
Location: somewhere in NJ or PA
Posts: 9,226
Mentioned: 1 Post(s)
Quoted: 3 Post(s)
Lifetime Premium Member
Send a message via AIM to Jippi Send a message via MSN to Jippi
change all the fuses your car will thank you. doesnt matter if they are still good or not


1993 MB 190E 2.3 105k- its alive.. 1996 Volvo 855 GLT-R 350k still rolling
1998 Subaru Outback SUS 210k- Daily Driver 2011 Toyota Camry XLE 36k
1991 BMW 525I stock as stock gets 98k (Wrecked) 1998 MB C230 209k possessed by the devil
Benzworld.org---Tri-State Crew
Jippi is offline  
post #8 of 33 (permalink) Old 02-20-2008, 09:28 PM Thread Starter
BenzWorld Member
 
Date registered: Feb 2008
Vehicle: 1991 mercedes-benz 190e 2.6
Location: boise, id
Posts: 183
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via AIM to alp_2420 Send a message via Yahoo to alp_2420
(Thread Starter)
did that already the day i bought it and cleaned all the terminals off and made them all shinny

Fat Tony
alp_2420 is offline  
post #9 of 33 (permalink) Old 02-21-2008, 10:49 AM Thread Starter
BenzWorld Member
 
Date registered: Feb 2008
Vehicle: 1991 mercedes-benz 190e 2.6
Location: boise, id
Posts: 183
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via AIM to alp_2420 Send a message via Yahoo to alp_2420
(Thread Starter)
so i tryed the aux motor and checked the relay behind the battery and nothing so im going to try a few more things and see if they work when one thing goes wrong in the system does the entire thing stop working??

Fat Tony
alp_2420 is offline  
post #10 of 33 (permalink) Old 02-21-2008, 04:06 PM Thread Starter
BenzWorld Member
 
Date registered: Feb 2008
Vehicle: 1991 mercedes-benz 190e 2.6
Location: boise, id
Posts: 183
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via AIM to alp_2420 Send a message via Yahoo to alp_2420
(Thread Starter)
so i didnt get to try anything elese on that DIY list of troubleshooting stuff but i did call a local benz repair shop and asked them if they knew and he had me try a few things and nothing and then ofcourse he said just bring it down and make an appointment blah blah blah but im still stuck wow wish you were closer or you cud just call me lol

Fat Tony
alp_2420 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > For Sale/Wanted/Trade/Giveaway

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Heater fan Donal Hayes V-Class 2 12-05-2007 04:29 AM
    Need a knob for my AC/Heater Fan Control charris R170 SLK-Class 13 01-22-2007 02:26 PM
    Loss of AC and Heater Fan Control Fiat8 W124 E,CE,D,TD Class 9 06-24-2005 02:59 PM
    126 HVAC Fan not working / Heater Fan Removal cam69ss W126 S,SE,SEC,SEL,SD,SDL Class 1 01-25-2005 11:31 AM
    Heater/Fan noise Tjærand G-Class 4 06-04-2002 10:46 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome