Looking for Argos kit for C230 2004 - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 01-03-2007, 11:32 AM Thread Starter
BenzWorld Junior Member
Date registered: Dec 2006
Posts: 18
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Looking for Argos kit for C230 2004

Hello .. i'm looking for someone to sell me Argos kit for Bluetooth for my C230 2004 with a good price
washoor is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > For Sale/Wanted/Trade/Giveaway

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Argos bluetooth kit w220 Audio & Telematics Forum 4 06-04-2015 09:32 AM
    Navigation on C230 2004 ..help washoor W203 C-Class 5 12-24-2006 02:13 PM
    Free Maintance on 2004 c230? baybama W203 C-Class 5 10-26-2006 07:07 PM
    FS- 2004 C230 Sedan yriley For Sale/Wanted/Trade/Giveaway 0 05-30-2005 05:58 PM
    2003 c230 or 2004? mulamutti W203 C-Class 2 09-29-2004 10:41 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome