Resetting the Service Indicator - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 08-29-2011, 10:20 AM
BenzWorld Member
 
Date registered: Jun 2009
Posts: 53
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Resetting the Service Indicator

I have a 2006 SL500 with the AMG accessory package. It is now ready for Service "B" Maintenance so I get that message everytime I turn the ignition on and it is annoying so I would like to reset it.

In doing research on how it is reset I've came across five different ways to do it. Two ways were from forums, the third way came from STAR TekInfo (http://www.startekinfo.com/StarTek/o...stedDocId=9521), the fourth way came from a shop manual I just installed, and the fifth came from a link in a forum to a copy of the Mercedes-Benz Reset Serice Indicator Guide (http://www.startekinfo.com/StarTek/o...tedDocId=10502), which would seem to be the best resource. All five methods were different and didn't work and I know that when I tried them repeatedly I did do them correctly.

So my question is; does anyone know how to reset the service indicator?

Thanks in advance.



06 SL500 w/AMG Sports Package
I LOVE IT!!!!!!!
hooperdoski is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 08-30-2011, 08:42 PM
BenzWorld Member
 
PLeeson's Avatar
 
Date registered: Apr 2007
Vehicle: 2012 E350 4Matic
Location: Iowa
Posts: 351
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
As per 2003 Owner's manual:
Ignition on
Arrow buttons until service symbol (wrench) appears on display.
Press reset knob for about 4 seconds.
See "do you want to reset..." message, hold down reset button again until you hear signal.
Done

Phil

Prior MBs:
1971 250, 1983 380SEL
1986 190E2.3, 1987 300TD
1994, 2003, 2005 SL500s
2001 E320 4Matic
2011 E350 4Matic
PLeeson is offline  
#3 (permalink) Old 08-31-2011, 03:57 PM
BenzWorld Member
 
Date registered: Jun 2009
Posts: 53
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
I tried it and it didn't work. I believe Mercedes changed systems to the same as mine in 2005.

Thanks for the info.



06 SL500 w/AMG Sports Package
I LOVE IT!!!!!!!
hooperdoski is offline  
#4 (permalink) Old 08-31-2011, 08:53 PM
BenzWorld Member
 
PLeeson's Avatar
 
Date registered: Apr 2007
Vehicle: 2012 E350 4Matic
Location: Iowa
Posts: 351
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2003 to 2007 use that procedure.
2008 and up use a slightly different one.
MBworld has a post in the W203 section that has the MB guide as of 3/2009

Phil

Prior MBs:
1971 250, 1983 380SEL
1986 190E2.3, 1987 300TD
1994, 2003, 2005 SL500s
2001 E320 4Matic
2011 E350 4Matic
PLeeson is offline  
#5 (permalink) Old 09-16-2011, 06:24 PM
BenzWorld Member
 
Date registered: Jun 2009
Posts: 53
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
I forgot about this thread because I got rid of the service message. However, Pleeson had it right. I tried it several times and it didn't work, but when you turn the key to the two positon and the service message comes up so you need to use the arrow button to bring it up again. Then it works.

Here's the notes I've written so I won't forget how to do it next year.

Resetting the Service Indicator

1. Turn key to number two position
2. You will see the service message
3. Use the arrow key to cycle to the service message again
4. Hold down reset button until a message asks if you want to reset the service indicator
5. Let off the reset button when that message appears and then hold it down again until you get a message saying the reset has been done
6. Once message appears let off the reset button and then push it again and you will get a message telling you when the next service is due
7. Turn off key



06 SL500 w/AMG Sports Package
I LOVE IT!!!!!!!
hooperdoski is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Roadster Forums > R230 SL Class

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Resetting the Service A Indicator? Diggers W169 A-Class 18 04-02-2011 01:11 AM
Resetting Service Indicator Tom Haenisch W203 C-Class 3 08-29-2010 12:44 PM
resetting service indicator. rjg914 W251 R-Class 1 07-27-2008 11:04 PM
Help Resetting Service Indicator 08cls550guy W211 E-Class 7 04-13-2008 06:17 PM
Resetting Service Indicator slanford77 W211 E-Class 2 04-12-2007 07:10 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome