2003 SL500 Central locking fuse? - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Roadster Forums > R230 SL Class
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-31-2008, 09:54 AM   #1 (permalink)
BenzWorld Junior Member
 
Date registered: Apr 2007
Location: London
Posts: 10
2003 SL500 Central locking fuse?

Hey does anyone know where the fuse is for the central locking system? The locks don't work from the lock barrel, Remote or the switch on the dash...
Hope i hear some good news soon...................

Last edited by pyschopav; 01-31-2008 at 10:31 AM.
pyschopav is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-31-2008, 07:48 PM   #2 (permalink)
BenzWorld Elite
 
Date registered: Jan 2004
Vehicle: SL500, 300SL, 500SL
Location: Atlanta, USA
Posts: 2,165
It's the 20-amp fuse located in the rear fuse box module (picture). It is mounted under the storage compartment behind the right-side seat. You access the module by removing the interior trim panel. To do that pull outward at the top left of center and right of center to release two clips and then lift it upward and out.
Attached Thumbnails
2003 SL500 Central locking fuse?-fuse.jpg  
__________________
Many used parts available from a '92 SL. Email or PM for more information

Last edited by bobterry99; 12-30-2009 at 09:47 AM.
bobterry99 is offline   Reply With Quote
Old 02-04-2008, 01:16 PM   #3 (permalink)
BenzWorld Junior Member
 
Date registered: Apr 2007
Location: London
Posts: 10
Thanx Dude will have a look at it.....
Hopefully it is a blown fuse and it fixes the problem........
pyschopav is offline   Reply With Quote
Old 02-06-2008, 03:15 PM   #4 (permalink)
BenzWorld Junior Member
 
Date registered: Apr 2007
Location: London
Posts: 10
Fuse was blown, But new fuse poped after 5 seconds ... So looks like its the pump in the rear thats faulty
pyschopav is offline   Reply With Quote
Old 04-18-2009, 05:45 AM   #5 (permalink)
BenzWorld Newbie
 
Date registered: Mar 2009
Posts: 2
Bobterry, can you tell me if any of the fuses in the above picture are responsible for audio/headunit display?
Danoots is offline   Reply With Quote
Old 04-18-2009, 01:33 PM   #6 (permalink)
BenzWorld Elite
 
Date registered: Jan 2004
Vehicle: SL500, 300SL, 500SL
Location: Atlanta, USA
Posts: 2,165
Two of them: the 7.5-amp fuse at the bottom-left of the picture and the 5-amp fuse all the way to the right of the bank of fuses.
bobterry99 is offline   Reply With Quote
Old 04-18-2009, 02:15 PM   #7 (permalink)
BenzWorld Junior Member
 
Date registered: Apr 2009
Posts: 30
If you are planning to replace the locking pump unit yourself, very very easy !!
Just plug and play.

If the key does not work in the trunk lock (it should even with the pump faulty), you will only be able to access the trunk by opening the roof.

DO NOT CLOSE THE BOOT ONCE THE PUMP UNIT IS REMOVED.

With the pump unit removed you will NOT be able to open the roof again !

I have the holes in my trunk to prove it !
Daz54 is offline   Reply With Quote
Old 04-18-2009, 02:57 PM   #8 (permalink)
BenzWorld Junior Member
 
Date registered: Apr 2009
Posts: 30
pyschopaz.

This might sound a bit stange.

If its the worst case and your pumping unit is gone, I would offer to buy your old pumping unit - these pumping units are ridously expensive and i would love try and find a repair for them.

So i need a few broken units to play with - a SL pumping until is like $600 a C Class unit is $50 of ebay, how difference could them be - Has to be worth a try !


And all because of a MB design 'issue' !
Daz54 is offline   Reply With Quote
Old 04-17-2010, 03:15 PM   #9 (permalink)
BenzWorld Newbie
 
Date registered: Feb 2010
Posts: 2
does the lock fuse control the roof to?
lowblocks is offline   Reply With Quote
Old 04-18-2010, 02:50 AM   #10 (permalink)
BenzWorld Member
 
carlosamg's Avatar
 
Date registered: Jun 2005
Vehicle: SL500
Location: United Kingdom
Posts: 215
Hi bobterry99

Sorry to hijack the thread somewhat but after reading the previous post about adio display i wanted to ask if the instrument cluster display has a fuse ?.

My LCD displays go off then come on hen go off etc randomly and MB was £1500 GBP to replace the unit so i wanted to check things like fuses first to be sure that the power supply to the display is ok.

The needles, fuel gauge etc work 100%, just a fault with the LCD.

Thanks

Carl
carlosamg is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Roadster Forums > R230 SL Class

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Topic Author Forum Replies Last Post
Problem with VITO central locking and air suspension fuse Adrian_86 V-Class 11 01-26-2011 02:07 PM
01 s430 central locking fuse Keeps blowing NEU-BUG W220 S-Class 5 03-28-2008 06:15 AM
WTB: R129 SL500 Central Locking Vacuum Pump askay For Sale/Wanted/Trade/Giveaway 0 01-28-2008 10:00 PM
Central locking fuse?? slkdude433 R170 SLK Class 4 06-26-2006 09:02 PM
central locking & hardtop SL500 rsilva R230 SL Class 1 06-23-2005 11:42 PM


All times are GMT -7. The time now is 08:43 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.