help? SLK 230 battery cut-off relay problem - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 03-25-2011, 10:10 PM
BenzWorld Junior Member
 
Date registered: Mar 2011
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
help? SLK 230 battery cut-off relay problem

Any help with the known K56 battery cut-off relay problem on 98 SLk230 ??

I replaced the batt and alt before realizing they weren't the problem so both test good. After I replaced the battery cut-off relay, nothing changed. The "G" post on the relay has 19+V and the "battery" post has 12.2V (less with the lights or other stuff on).

In other words, the relay is not passing the charge on to the battery even though the alternator is maxed.

Anyone know where the signal comes from that throws the relay off? Could a false crash detection signal from some inertial switch have blown the new relay already? If I just jumper around the relay will the regulator still control the charging level so I dont fry my battery? I don't really care if I'm a tiny bit less safe in the event of a crash, I just want to be able to drive without wonderingwhen my battery will go dead in traffic.

Ernie
erniel2 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 03-25-2011, 10:49 PM
BenzWorld Junior Member
 
Date registered: Mar 2011
Vehicle: A Faster car than Yours
Location: USA
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
the k56 relay module causes many strange issues with these eary vehicles...that is where i would start. there is no user servicable parts inside, or i would tell you. i bet a simple 125 diagnosis charge at your dealer would have saved you alot of money if you bought a battery and alternator already chasing a ghost problem......
dealermastermechanic is offline  
#3 (permalink) Old 03-26-2011, 12:16 AM
BenzWorld Junior Member
 
Date registered: Mar 2011
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Gee, thanks for the non-advice. Note that I already replaced the k56. Everything is new. I need to know if I can jumper across its posts safely and what alternate sources might be causing the relay to interrupt the charging.

What could really help is if someone could tell me what the correct voltages are at each pin of the plug. There must be a signal to trip the relay and it must've tripped the new one as well as the one I took out. What a nonsense device anyway. How many decades did cars work just fine without having the battery disconnect in every fender bender?
erniel2 is offline  
#4 (permalink) Old 03-26-2011, 03:00 AM
Moderator
 
Subby_'s Avatar
 
Date registered: Jan 2007
Vehicle: 1998 SLK 230
Location: Melbourne, AU
Posts: 2,162
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Lifetime Premium Member
the airbag sends the trigger signal to blow the fuses in the relay... once fuses are blown in the relay battery will not charge.
Attached Files
File Type: pdf crash_relay.pdf (116.1 KB, 454 views)

- ASP pulley kit
- 87mm supercharger pulley
- Ported Eaton M62 supercharger
- Ported supercharger inlet manifold
- MAF screen & throttle body screen delete
- Automatic intercooler spray kit
- Single 2.5" Magnaflow Hi-flow cat
- Magnaflow rear muffler + Lukey Ultraflo resonator
- Shift-I progressive shift light
- Custom ECU tune
- Air box delete (custom) with BMC airfilter
- 10c degree STAR thermo fan mod
- FireStorm igntion coil booster
- PIVOT Raizin voltage stabilizer
Subby_ is offline  
#5 (permalink) Old 03-26-2011, 01:33 PM
BenzWorld Junior Member
 
Date registered: Mar 2011
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Thank you Subby! I'm learning more and more.about this finnicky device. Other than the risk of fire (in the event of an accident) it was designed to prevent, do you see any harm that'd be done by simply connecting the posts of the K56 and bypassing the relay?

Obviously I need to track down the flaw in the airbag deployment sensor so it doesn't fail in a crash, resulting me being both crushed AND burned to death but meantime I'd like to be able to drive the car.
erniel2 is offline  
#6 (permalink) Old 03-26-2011, 01:44 PM
BenzWorld Junior Member
 
Date registered: Mar 2011
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Also, has anyone replaced their airbag activation unit or related circuit board to correct the false signal to the battery cut-off? is it difficlt? where is it located?
erniel2 is offline  
#7 (permalink) Old 03-28-2011, 09:24 AM
BenzWorld Member
 
Date registered: Feb 2006
Vehicle: 98 SLK230, 05 C-240T
Location: Lexington Park, MD
Posts: 135
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
My K56 relay blew when I left the car with the top down in a thunderstorm. I jumped the terminals until I could get a new relay. It was no problem, and the voltage regulator functioned normally. The relay (it's really a sophisticated fuse) interrupts the connection between the alternator and the battery.
ERFOY is offline  
#8 (permalink) Old 03-28-2011, 10:09 AM
BenzWorld Elite
 
Benznoob26's Avatar
 
Date registered: Jul 2009
Location: under cars
Posts: 2,042
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to Benznoob26
I just got my car, and have an invoice something about a relay burning out the battery every night. Ill go look at it but off the top of my head the original stereo was drawing power from the battery while the car was off. So now it has an aftermarket unit, I know some wires were replaced but ill go double check
Benznoob26 is offline  
#9 (permalink) Old 03-28-2011, 02:19 PM
BenzWorld Junior Member
 
Date registered: Mar 2011
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
SRS, k56, misc. electrical

Okay I jumpered my battery cut-of relay (K56) and the charging system works normally again. I'm beginning to think that the relay failure was caused by water leaking into the cabin as was the case with other people on this thread.

The drains clogged in the cowling below the windshield and water was sloshing around and overflowing on to the passenger floorboard. It was soaked for a long time before the relay blew out. Now my SRS light is on, the right channel of the stereo failed, and the new K56 I installed blew out immediately.

There are apparently a ton of electrical systems housed or passing under the dash and floorboards on the passenger side. Many have stated that their electrical probs disappeared after the car dried out thoroughly. The SRS light may need to have the codes cleared in order to not light up any more.

I am just going to run it with the relay jumped until it's completely dry inside and then maybe put a new relay in. The risk is thatif I crash, a fire is more likely but that's te only down side I can see. The only circuit that will be hot that would not be if the relay was funtional is the wire from the G(enerator) post to the alternator output which would ordinarily get turned off when the key was off or if there was a crash with airbag deployment.

Is there anything else besides the alternator attached to that circuit below the relay that might draw power with the key off or create a hazard? Seems unlikely...
erniel2 is offline  
#10 (permalink) Old 11-25-2012, 06:55 AM
BenzWorld Member
 
Date registered: Dec 2006
Vehicle: 1998 slk230
Location: Tallahassee FL
Posts: 88
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Old thread, I know. But new problem for me. I'm fairly certain the crash relay burnt out or whatever. All my gauges went dead but made it back to my office and the car is dead now.

Can any explain how exactly you bypassed the crash relay till you got a new one? I'm getting the car towed home and will try that out but don't want to fry out anything else. Thanks
tallylynn is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Roadster Forums > R170 SLK Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
SLK 230 OX2 also K40 Relay DOUBLE R170 SLK Class 7 10-21-2008 10:56 AM
My slk 230 cut off and won't start again kevinHK R170 SLK Class 3 12-06-2006 06:14 AM
SLK 230. Fuel cut - is that supposed to be like that? raffe R170 SLK Class 3 04-16-2005 08:15 PM
K40 relay box on slk 230 techs only , slklover R170 SLK Class 0 02-04-2005 04:53 PM
GUYS !!! I have a third "version" slk 230 air filter mods without cut hole in...................... Linh R170 SLK Class 14 03-25-2002 02:44 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome