hardtop convertible issues - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 03-31-2009, 08:22 PM
BenzWorld Junior Member
 
Date registered: Mar 2009
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
hardtop convertible issues

hows it goin everybody, new to the site and im excited to see how much help everyone is on here, so heres my problem

i just purchased a 1998 slk 230, the top went down just fine, drove for a few hours, then when i got home and tried to put the top up, the roof came up and latched but the trunk wouldnt close.. it just stayed in the up position... so i pushed the switch to open and it retracted inside the trunk all the way no problem... when i got home and tried it again the same thing happened... top goes up but the trunk will not close... and now it wont do anything... the motor does not run, no pump actuation noise or anything

so now here i am, convertible top is up and latched, the trunk is up backwards, all the windows are down, and nothing is working at all... i can start the car with the parking brake on, and try the interior switch (which is lit up red, but not flashing) and it doesnt do anything...i took the plastic liner out from the inside of the trunk and there arent any leaks, the fuses in the trunk are fine (and i have the microswitch for the "roll cover" taped close as well so the computer reads that its in its proper position)since i had to disconnect from the plastic cover to get it out

besides this, is there a way i can manually close the trunk and get the top secured so i can move the car, i dont want to hurt anything on the car and have heard about manually close procedure but i dont have an owners manual to the car, any and all help will be greatly appreciated..
shandapanda is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 03-31-2009, 09:35 PM
BenzWorld Junior Member
 
Date registered: Mar 2009
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
k heres the update, i found online where u can bleed the pressure on the system with an allen key... did that and now the top is secured and the trunk is closed (and will open the conventional way as well) but the rear windows are still down and the top still does nothing... i have been researching all day but can find the answer to my question.. so first off is there any way i can get the rear side windows back up so i can at least drive it... id like to figure out why the top isnt working but my priority now is just getting those windows up so i can drive it tomorrow
shandapanda is offline  
#3 (permalink) Old 04-01-2009, 08:24 AM
BenzWorld Extremist
 
nickwilcock's Avatar
 
Date registered: Oct 2005
Vehicle: 2003 SLK32 AMG Designo
Location: British West Oxfordshire, UK
Posts: 839
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Unfortunately, according to the Operator's Manual, the rear side windows cannot be raised manually.

Is this link http://www.justanswer.com/questions/...30-slk-put-top any help?

Last edited by nickwilcock; 04-01-2009 at 08:34 AM.
nickwilcock is offline  
#4 (permalink) Old 04-01-2009, 10:39 AM
BenzWorld Junior Member
 
Date registered: Mar 2009
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
so how do u recommend i fix this... as of right now i took the plastic sides out of the trunk and didnt find any leaks or cut wires, the fliud level in the compressor is fine too... and i closed the switch that senses if the roll up cover is closed as well since i took that stuff out to inspect everything (the motor wasnt running before i removed the plastic just fyi)

so are there any fuses or relays that i can try first since the motor does nothing at all,,, and if thats not the case i figure i could test the switch in the trunk first then the ones located bu the rearview mirror and so on and soforth... just trace all the switches till i find the on that is faulty

but im not sure how to test the switches.. any help on this would be greatly appreciated... ill send a chocolate chip cookie to the person that leads me in the right direction
shandapanda is offline  
#5 (permalink) Old 04-01-2009, 01:29 PM
BenzWorld Junior Member
 
Date registered: Mar 2009
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
just talked to a mercedes guy and he told me the only way to know was to take it to the dealership and get them to hook it up to the computer and it will tell me which sensor is switched... lookin like some big bucks
shandapanda is offline  
#6 (permalink) Old 04-01-2009, 02:18 PM
BenzWorld Senior Member
 
cacecef's Avatar
 
Date registered: Apr 2007
Vehicle: 98 red 230 slk
Location: dallas, tx
Posts: 454
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Start with the rear trunk sensor 1st. Put the screw back in on the hydralic pump and see what happens when you try to lower using the top switch. Fast blinking only, probably your trunk switch is out. Solid light, no blink, no pump sound, probably means your hydra pump is shot or fuse is blown. Or your low on hyda fluid.
cacecef is offline  
#7 (permalink) Old 04-01-2009, 03:01 PM
BenzWorld Elite
 
oberoi's Avatar
 
Date registered: Mar 2006
Vehicle: 2010 C200cgi W203/SLK230/C180/230E/280SE
Location: Sydney Australia
Posts: 3,170
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
you may have overworked your 40 amp fuse under the bonnet/hood - check 23 or 24 (LH side facing engine near brake fluid canister - explanatory card in lid)

Oberoi
oberoi is offline  
#8 (permalink) Old 04-01-2009, 06:00 PM
BenzWorld Junior Member
 
Date registered: Mar 2009
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
sorry to sound like an idiot but i cannot find the fuse... in the fuse box (the one by the brake boster on the drivers side) they are numberedbut they skip 19-29... it goes from fuse 18 (spare) to 30 (heated seat) sorry if im pullin a rainman on this but ive looked everywhere
shandapanda is offline  
#9 (permalink) Old 04-01-2009, 07:00 PM
BenzWorld Elite
 
oberoi's Avatar
 
Date registered: Mar 2006
Vehicle: 2010 C200cgi W203/SLK230/C180/230E/280SE
Location: Sydney Australia
Posts: 3,170
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
It's no 25 - 3rd one down on the right - Hydraulic unit - should be orange 40amp (mine are painted white because at one time I was changing fuses every day - lube problem)

Bruce
Attached Thumbnails
Click image for larger version

Name:	DSC02445.JPG
Views:	317
Size:	133.1 KB
ID:	230603   Click image for larger version

Name:	DSC02446.JPG
Views:	342
Size:	147.9 KB
ID:	230604  
oberoi is offline  
#10 (permalink) Old 04-01-2009, 09:38 PM
BenzWorld Junior Member
 
Date registered: Mar 2009
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
wow thank u for goin through all that trouble... mine is a 1998 and the diagram is different (and the fuse box) but i checked all the fuses and everything checked out just fine... even the 40 amps at the top...

while i was at it i checked the rear switch with my ohm meter and it closed the circuit just like it should... do i need to check that with all the microswitches or am i just wasting my time
shandapanda is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Roadster Forums > R170 SLK Class

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Hardtop Convertible on an older Merc? derelyth General Mercedes-Benz 6 01-07-2009 07:51 AM
new BMW Z4, hardtop convertible! cyberdrakon Off-Topic 15 12-14-2008 05:29 PM
FS: SL/R129 convertible hardtop hoist musicmax For Sale/Wanted/Trade/Giveaway 3 06-05-2008 08:29 PM
OT: VW EOS Hardtop convertible is available Kirill R170 SLK Class 5 01-09-2007 06:25 AM
300GD convertible with hardtop for sale Mike_G G-Class 5 07-05-2003 10:29 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome