SLK 320 Transmission Problem - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Roadster Forums > R170 SLK Class
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-13-2007, 10:44 AM   #1 (permalink)
BenzWorld Junior Member
 
Date registered: Aug 2005
Posts: 7
Unhappy SLK 320 Transmission Problem

I have an automatic 2002 SLK 320 with 48K miles and all regular services done on schedule. Yesterday when I shifted from park to reverse, I heard a clunk, then again from neutral to drive. Then while driving I noticed that the transmission would not shift up, it stayed in first gear, even when I tried the manual shift it would not shift. I stopped on the side of the road, (Oh so embarrassing) shut the car off for about 90 secs, restarted and it worked fine. I thought maybe it was a computer or electrical hiccup. However, it did the exact same thing this morning again. Does anyone have any idea what may be going on? I called the dealer, they will not tell me if it is covered under the extended power train warranty and I am scheduled to take it in on Monday but I am having car repair payment anxiety.
911FNP is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-13-2007, 12:36 PM   #2 (permalink)
BenzWorld Elite
 
slk230red's Avatar
 
Date registered: Mar 2004
Vehicle: '01 SLK230,'93 190E 2.3, 1971 LS5 Corvette Convertible
Location: Tampa, FL
Posts: 1,872
When this problem happened to my 2001 SLK230 in Aug. 2004 with 28,321 miles, it was hard to get out of park and when it did, it would bang into drive and not shift...it stayed in 3rd gear. I assume it was in "limp mode".

It turned out to be the Electronic Selector Module. Part number 1702671124. $284.04 for the part.
Mine was covered under factory warranty. I would think that your extended warranty would cover your problem.

Good luck,

Dave
__________________
slk230red is offline   Reply With Quote
Old 10-13-2007, 01:09 PM   #3 (permalink)
BenzWorld Elite
 
Bazzle's Avatar
 
Date registered: Apr 2005
Vehicle: Golf R32 / Prev R170 SLK
Location: Melbourne, Australia
Posts: 6,821
Hopefully it may only need a drain and refill with FILTER change.
The diffs on these get play in the planetries and make a clunk. Its something you only hear when you get worried

Bazzle
Bazzle is offline   Reply With Quote
Old 10-13-2007, 01:17 PM   #4 (permalink)
BenzWorld Junior Member
 
Date registered: Aug 2005
Posts: 7
I really hope it is a Module or a Fluid & Filter change. Thanks Guys.
911FNP is offline   Reply With Quote
Old 10-14-2007, 08:18 AM   #5 (permalink)
BenzWorld Junior Member
 
CTODWC's Avatar
 
Date registered: Jul 2007
Vehicle: 2001 SLK 320
Location: New Braunfels, Texas
Posts: 21
Went through this “anxiety attack” this past July with my ’01 SLK 320.
Had these symptoms:
Difficult shifting from P to D or R, clunking when shifting, 2nd gear only in D, dash display for transmission incorrect.
Computer diagnosis showed P0705 code.
Suggestion: If it’s in warranty, let MB deal with it.
If not, clear any and all codes from the computer (to include service codes).
Start car; let it idle down < 1K RPM, pump brake vigorously (brake light switch) and see if problem goes away.
Why? That’s what I did and the problem went away w/o replacing any parts.
BTW … the anxiety still remains.
__________________
~ Es ist was es ist ~
CTODWC is offline   Reply With Quote
Old 10-16-2007, 08:46 PM   #6 (permalink)
BenzWorld Senior Member
 
Date registered: May 2006
Vehicle: 2002 SLK32 Silver Renntech pullies
Location: Maryland
Posts: 438
Quote:
Originally Posted by Bazzle View Post
Its something you only hear when you get worried

Bazzle
I am one of those type of person.

Jerry
jerryxu is offline   Reply With Quote
Old 10-17-2007, 02:19 AM   #7 (permalink)
BenzWorld Junior Member
 
Date registered: Aug 2005
Posts: 7
Well, I went to the dealer and it turned out that I am actually out of warranty. Imagine that, I was lied to by a used car salesman! The warranty timed out in April. Anyhow, they said that they would have to replace the tramsmission conduction plate and the brake light switch based on the codes from the check engine light. Since I was out of warranty, parts and labor was $1284.00 Hesitantly, I agreed and had the work done. Picked up the car yesterday and went to work last night, all is well, until this morning, when I cranked it up, it turned over slowly like the battery was dead, however after two cranks it came alive and I drove home uneventfully. The worse was yet to come. When I was ready to leave home for work, I heard the same clunk from park to reverse and then the same problem as before I spent $1284.00, it would not shift. So 2 days and $1284.00 later, I am still in the same position. I am heading back to MB of South Atlanta this morning to have a chat with the service person and possibly the service manager.
911FNP is offline   Reply With Quote
Old 10-17-2007, 04:20 AM   #8 (permalink)
BenzWorld Elite
 
papa's Avatar
 
Date registered: Jun 2006
Vehicle: SLK 320 BRABUS Modded
Location: Wales UK
Posts: 2,396
A CHAT ?


I would be having more then a chat, They would remeber me for a wile after.
__________________


I think of you all as friends but if zombies chase us I'm tripping you !

Joke ......... What go's clop clop clop bang clop clop clop bang....A amish drive by shooting


Fact ............... Human taste buds are sensitive enough to identify one drop of lemon juice diluted in 129,000 drops of water.
papa is offline   Reply With Quote
Old 10-17-2007, 02:15 PM   #9 (permalink)
BenzWorld Elite
 
Kobus's Avatar
 
Date registered: Apr 2007
Vehicle: 2001 SLK 320(178K Miles), 2002 E320 Special Edition(156K Miles)
Location: South Bay Area,L.A., CA
Posts: 3,326
Quote:
Originally Posted by 911FNP View Post
they would have to replace the transmission conduction plate and the brake light switch based on the codes from the check engine light..
What is a transmission conduction plate?
Kobus is offline   Reply With Quote
Old 10-17-2007, 02:28 PM   #10 (permalink)
BenzWorld Junior Member
 
Date registered: Aug 2005
Posts: 7
The report from the dealer called it a transmission conductor plate part number 140-270-08-61 I had to replace the battery this morning and all seems to be in order now. Driving with fingers crossed and will never have anything done at MB South Atlanta ever again.
911FNP is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Roadster Forums > R170 SLK Class

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Topic Author Forum Replies Last Post
CLK 320 Water Spill Transmission shifting problem Italiano731 W208 CLK Class 16 10-30-2006 12:48 AM
2000 SLK 320 auto-transmission problems and more heather R170 SLK Class 5 10-20-2001 12:57 PM
SLK 320 Sport Problem Tiffany R170 SLK Class 4 07-15-2001 09:15 AM
SLK 320 MT Clutch problem -help please Stuart R170 SLK Class 1 03-24-2001 02:30 PM
SLK 320 6-speed clutch problem Jonjon R170 SLK Class 3 01-18-2001 07:26 PM


All times are GMT -7. The time now is 07:35 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.