HELP! intermittent start & engine stall problem ? - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Roadster Forums > R170 SLK Class
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-11-2004, 06:33 AM   #1 (permalink)
BenzWorld Member
 
Date registered: Nov 2004
Posts: 51
HELP! intermittent start & engine stall problem ?

my 230 K 1998 silver only 46,0000 miles
having random engine start problems and also cuts out whilst driving (aarrrgggg - dangerous )
been to dealer no show on computer diagnostics
they replaced ignition switch (£100) still got
problem. breakdown recovery man yesterday thinks it
may be alarm fault ?
i can be sitting in car for a few mins. or over 2
hours then it will suddenly start ?
HELP
[:(][V]
mikeallan is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-11-2004, 07:50 AM   #2 (permalink)
BenzWorld Member
 
Date registered: Mar 2004
Vehicle: 2002 SLK 32 /////AMG
Location: Texas
Posts: 128
RE: HELP! intermittent start & engine stall problem ?

Take it to another dealer immediately. It's a very dangerous thing to be driving a car with that kind of a problem. DON'T GET HURT. Fix it!
Sesh is offline   Reply With Quote
Old 11-11-2004, 10:08 AM   #3 (permalink)
BenzWorld Elite
 
DEATHERAGE's Avatar
 
Date registered: Jun 2004
Vehicle: 2001 SLK 230
Location: Phoenix Arizona
Posts: 1,226
Send a message via ICQ to DEATHERAGE Send a message via AIM to DEATHERAGE Send a message via MSN to DEATHERAGE Send a message via Yahoo to DEATHERAGE
RE: HELP! intermittent start & engine stall problem ?

spark plugs?
__________________
ASP Pulley Kit, Valentine One Radar Detector Hardwire, Momo Shift Knob, Huber Optic Tint, Vario Roof Commander, Cross Driller Rotors, Porterfield Powderless Brake Pads.
DEATHERAGE is offline   Reply With Quote
Old 11-12-2004, 06:31 AM   #4 (permalink)
BenzWorld Member
 
Date registered: Nov 2004
Posts: 51
RE: HELP! intermittent start & engine stall problem ?

not spark plugs !
when I turn key the dash lights work.cd.fan. ect.
but sometimes there is no feed to starter.?
had full service and brake dics/pads
replaced ignition switch - no effect
recovery engineer says it may be alarm/immobilser
fault .
booked into dealer again next week (if it starts? lol)
ANY IDEAS ?
mikeallan is offline   Reply With Quote
Old 11-12-2004, 09:40 AM   #5 (permalink)
BenzWorld Extremist
 
BlueBenz's Avatar
 
Date registered: Sep 2002
Vehicle: SLK 230
Location: LONDON / Middlesex , England
Posts: 1,007
RE: HELP! intermittent start & engine stall problem ?

Hi Mikeallan
Where abouts are you based ? I know a great workshop in Uxbridge, independent but merc trained/qualified/donkeys years of experience.
They may be able to help, and won't fob you off by just replacing parts, they will actually investigate.
Company is called Trident, 01895 814640, tell 'em Stu sent you.
BlueBenz is offline   Reply With Quote
Old 11-12-2004, 08:39 PM   #6 (permalink)
BenzWorld Senior Member
 
Kühl Carbon's Avatar
 
Date registered: Aug 2002
Vehicle: 1999 SLK230
Location: Orchard Lake, Michigan
Posts: 592
RE: HELP! intermittent start & engine stall problem ?

Absolutely positively the "Crank Position Sensor". Mine did the same thing and it is known to go bad. When it fails it does not throw codes. Your symptoms are exactly as mine were and the only way for the dealer to diagnose the problem, is to replace it.
__________________
Hi []

Kühl Carbon is offline   Reply With Quote
Old 11-13-2004, 08:00 AM   #7 (permalink)
BenzWorld Member
 
Date registered: Nov 2004
Posts: 51
RE: HELP! intermittent start & engine stall problem ?

thanks for that bluebenz -
but i live in Medway, Kent & i would not trust
this pile of poo to get me there Alive ?
i have had zozens of prestige cars in my 55 years
but None have been as frustrating and potentially
dangerous as this one !

mikeallan is offline   Reply With Quote
Old 11-13-2004, 08:32 AM   #8 (permalink)
BenzWorld Member
 
Date registered: May 2004
Vehicle: SLK 230 98'
Posts: 88
RE: HELP! intermittent start & engine stall problem ?

Mine did that too. The dealer replaced something they called (translated from Norwegian) ground module or base module. I don't know if that gives you any clues, but that thingie is suppusingly responsible for managing all the electric stuff in the car.

Rafael
raffe is offline   Reply With Quote
Old 11-14-2004, 03:24 AM   #9 (permalink)
BenzWorld Member
 
Date registered: Nov 2004
Posts: 51
RE: HELP! intermittent start & engine stall problem ?

Thanks
I have been told on another forum that it may be the
"ENGINE CONTROL MODULE" - also the guy from Norway on this forum says that too - i think ?
Were your symptoms just like mine?
go to car - starts 1st turn
drives no prob.-park up -do shopping-return
NOTHING??? - try again & again - NOTHING -call out recovery, whilst waiting (up to 2 hours) - try again - STARTS?????
drive along engine dies ? - turn key - NOTHING -push car to safety -turn key -STARTS??? - drives home fine ?
please let me know?
mikeallan is offline   Reply With Quote
Old 11-14-2004, 03:41 PM   #10 (permalink)
BenzWorld Member
 
Date registered: May 2004
Vehicle: SLK 230 98'
Posts: 88
RE: HELP! intermittent start & engine stall problem ?

Quote:
mikeallan - 11/14/2004 6:24 AM

Thanks
I have been told on another forum that it may be the
"ENGINE CONTROL MODULE" - also the guy from Norway on this forum says that too - i think ?
Were your symptoms just like mine?
"ENGINE CONTROL MODULE" might be the right description for the unit I got replaced in my car. Your description of the problem sounds very much like mine, that is including calling out recovery![:)]

I had two incidents before I got my car fixed. One of them was when I parked the car for 10 min. Then when I tried to start the enigine - no response. But all the other electric stuff worked (lights, roof, etc...). One hour later when the recovery guy tried to start the enigine, the car worked perfectly.

Another time (next day) the engine just died on me in the middle of the road while driving. Same procedure - wait and try again. This time it took only 5 - 10 min. untill it started acting normally again.

Since that started the same day I got my car from they dealer, they fixed it for me immideatly.

Rafael

raffe is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Roadster Forums > R170 SLK Class

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 05:12 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.