Soft Top Stuck on 1999 SL500 - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Roadster Forums > R129 SL Class
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-22-2010, 09:24 PM   #1 (permalink)
BenzWorld Junior Member
 
yeahmeknows's Avatar
 
Date registered: Mar 2010
Vehicle: 99' Mercedes SL500
Location: Los Angeles, CA
Posts: 14
Send a message via AIM to yeahmeknows
Soft Top Stuck on 1999 SL500

Hi,

I purchased a 1999 Mercedes SL500 and it's beautiful, it's only fault is that the soft top is not coming up.

I have managed to remove the hardtop manually with the Top-Toolkit and put it in my garage (it couldn't pop out also) but when I press on the red button (up or down) to open the Soft Top, I hear the system's noise trying to work but nothing happens and from the front windshield I have oil leaking out where the sun visors are.
Same thing for the roll bar, I hear the system trying to work but nothing else happens.

What seems to be the problem? can I raise the soft top manually? I can't seem to even open the lid for it, it's too strong.

Thanks a lot!

Last edited by yeahmeknows; 03-22-2010 at 09:28 PM.
yeahmeknows is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-22-2010, 10:09 PM   #2 (permalink)
BenzWorld Elite
 
bearone2's Avatar
 
Date registered: Apr 2008
Vehicle: 2000 SL500 SL2 Triple Black
Location: Phoenix, AZ
Posts: 1,410
leaks in the front cylinders for sure, maybe in others also, so you're low on fluid.

this is one of the reasons to get a ppi/pre-purchase inspection before buying the car.

there's a good write-up about the rst system for the soft top in the stickies.
__________________
2000 SL500 SL2

"Common sense isn't as common as it once was!"

"Good judgment comes from experience which comes from bad judgment."
bearone2 is offline   Reply With Quote
Old 03-23-2010, 08:38 AM   #3 (permalink)
BenzWorld Elite
 
msbarsi's Avatar
 
Date registered: May 2006
Vehicle: 2000 Obsidian Black Metallic Mercedes SL 320 V6
Location: Northern Italy near Milan
Posts: 4,476
Send a message via Skype™ to msbarsi
yeahmeknows hi and welcome in our big and international friendly family. Please update your profile with your car, year and location to help us help you in the best and quickest possible way.

Please get familiar with the 3rd blue sticky thread as there are all the info you need to know for your problem regarding the soft top.

Cheers.
__________________
I drive like I stole . . . YOURS
msbarsi is offline   Reply With Quote
Old 06-12-2010, 07:40 PM   #4 (permalink)
BenzWorld Junior Member
 
yeahmeknows's Avatar
 
Date registered: Mar 2010
Vehicle: 99' Mercedes SL500
Location: Los Angeles, CA
Posts: 14
Send a message via AIM to yeahmeknows
99' SL500 Top & Windows Controllers not functioning

Hello!

I have a very strange problem in my 1999 SL500 I've been struggling for weeks now.

For some reason, the top controller + windows controllers do not functioning AT ALL.
The LED lights inside the top and roll bar control buttons is constantly ON and solid red.

The biggest problem is I cannot close any of the doors because the windows are not functioning at all, meaning they won't lower down automatically to allow the door to open and close properly.

When I disconnect the battery and reconnect it after 5 minutes the issue is fixed and gone but keeps coming back after turning off the car.
Also I checked all the fuses in the car and they are all working perfectly.
I also attached the Hard Top back in hope the system will reset itself, the car sucked the hard-top in but it did not solve anything and now it's stuck in it's place lol (which is not a big deal I just want to solve the problem).

I'm attaching pictures of the problem and it also shows how the window did not lower down when I want to close the door (not to mention it does not work at all no matter what).

Please help! I really appreciate it!
Thank you in advance
Attached Thumbnails
Soft Top Stuck on 1999 SL500-s7302753.jpg   Soft Top Stuck on 1999 SL500-s7302754.jpg   Soft Top Stuck on 1999 SL500-s7302755.jpg   Soft Top Stuck on 1999 SL500-s7302756.jpg   Soft Top Stuck on 1999 SL500-s7302757.jpg  

yeahmeknows is offline   Reply With Quote
Old 06-12-2010, 09:18 PM   #5 (permalink)
RKH
BenzWorld Elite
 
RKH's Avatar
 
Date registered: Apr 2008
Vehicle: 1998 SL500 Panoramic Roof
Posts: 7,969
Scan for codes. You need the widows and rollbar working before the top operation can function. If you have already ruled out the fuses, and it is unlikely both window motors are bad at the same time, then the controller is next. Try disconnecting the battery overnight to see if it clears the codes.
RKH is offline   Reply With Quote
Old 06-12-2010, 10:16 PM   #6 (permalink)
BenzWorld Junior Member
 
yeahmeknows's Avatar
 
Date registered: Mar 2010
Vehicle: 99' Mercedes SL500
Location: Los Angeles, CA
Posts: 14
Send a message via AIM to yeahmeknows
Quote:
Originally Posted by RKH View Post
Scan for codes. You need the widows and rollbar working before the top operation can function. If you have already ruled out the fuses, and it is unlikely both window motors are bad at the same time, then the controller is next. Try disconnecting the battery overnight to see if it clears the codes.
Hi!
I appreciate your comment.

I'm not feeling very comfortable disconnecting the battery overnight, it seems too sensitive and I'm afraid it will ruin the computer.

Is there any other way to reset the codes completely other than taking it to a mechanic?

Thanks again!
yeahmeknows is offline   Reply With Quote
Old 06-12-2010, 11:13 PM   #7 (permalink)
RKH
BenzWorld Elite
 
RKH's Avatar
 
Date registered: Apr 2008
Vehicle: 1998 SL500 Panoramic Roof
Posts: 7,969
You can buy some tools to do the scan and reset most codes yourself, but they don't work on the RST controller. The only one that works with the RST controller is from MB and $$$. (Not many Shop have that either as it is expensive).
RKH is offline   Reply With Quote
Old 06-13-2010, 01:43 AM   #8 (permalink)
Moving on
 
lynns's Avatar
 
Date registered: Jul 2006
Vehicle: Y2K SL500 Silver
Location: So. California
Posts: 8,661
How old is your car battery and do you feel good that it is putting out 13.7 Volts with the engine running? I always raise and lower my RST with the engine running and the battery charging.

If you have NOT done the following steps please do the following.

1) With the car out of the garage and the engine running lower both of the side windows with the console switches.
2) With the hard top ON and both doors shut raise each window and hold the window button in the up position for 10 seconds. Then lower both windows. This synchronization is VERY important and can be found in your Owners Manual.
3) Hold the roll-over bar switch in the up position for approx. 10 seconds or until you hear a slight click sound that should reset the roll bar. Now lower the roll bar. This is NOT in your Owners Manual.
4) Now pull the red hard top button to the back position until the hard top releases. Remove the hard top.
5) With the engine running push the red soft top button forward and hold it until the soft top comes out of the compartment and completes it's cycle.

6) If the above doesn't work please check the soft top hydraulic fluid pump reservoir level. Located under the spare tire in the trunk. If the fluid is down you may have a leak in the CLOSED system that needs repair and/or hydraulic fluid added until you can find the leak.

7) If none of this works I would suggest that you make a couple of phone calls to your local MB Independent repair shops and ask them if they have a MB STAR Diagnostic System (SDS) and what they would charge you to read and erase your Roadster Soft Top (RST) Diagnostic Trouble Codes (DTC)'s. After they erase the codes and the top is functioning drive the car around the block and back to the Indy shop and cycle your soft top 1-3 times to make sure that the codes have ALL been completely erased.

This should cost you no more than $50-$85.00.

Last edited by lynns; 06-18-2010 at 12:54 AM.
lynns is offline   Reply With Quote
Old 06-13-2010, 03:40 AM   #9 (permalink)
BenzWorld Moderator
 
NEOKEN's Avatar
 
Date registered: Dec 2007
Vehicle: 95 SL500, K&N, NEOKEN Ported TB, Custom Intake, RENNtech Sport Exhaust, AMG I Monoblocks
Location: Raleigh, NC
Posts: 10,308
Lifetime Premium Member
Quote:
Originally Posted by yeahmeknows View Post

What seems to be the problem? can I raise the soft top manually? I can't seem to even open the lid for it, it's too strong.
To manually open the RST storage compartment lid with ease, simply unlock both sides with the MB soft top wrench.

Please read useful Archived Topics before posting a new thread.
NEOKEN is offline   Reply With Quote
Old 06-13-2010, 10:45 AM   #10 (permalink)
BenzWorld Junior Member
 
yeahmeknows's Avatar
 
Date registered: Mar 2010
Vehicle: 99' Mercedes SL500
Location: Los Angeles, CA
Posts: 14
Send a message via AIM to yeahmeknows
Hey thank you guys for the replies and comments I really appreciate it!
Lynns, I will try the steps you have guided me through and will report back to see what's going on, I really hope it will work, because I have only 1 MB repair shop in my area and they are a bunch of idiots, last time they gave me back my car after maintenance without the tools bag, no spare tire and the dashboard was noisy so I try to avoid them as much as possible.

Thanks again! I will report back
yeahmeknows is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Roadster Forums > R129 SL Class

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Topic Author Forum Replies Last Post
2000 soft top stuck in compartment lynns R129 SL Class 14 01-12-2014 10:20 AM
1999 Soft top was stuck down and roll bar stuck up! jkmarsh R129 SL Class 18 08-03-2010 07:59 AM
Soft top stuck stewedg R129 SL Class 3 04-11-2009 03:16 PM
Soft top stuck question lightrod27 R129 SL Class 4 03-07-2009 05:11 PM
2000 SL600 soft top stuck half way mikem8 R129 SL Class 8 10-15-2007 10:55 AM


All times are GMT -7. The time now is 06:46 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.