Blinking gas gauge - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 07-23-2009, 09:22 AM
BenzWorld Member
 
RM98SL's Avatar
 
Date registered: Sep 2008
Vehicle: 98 SL500 , 012 CX9
Location: Upstate, South Carolina
Posts: 305
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Blinking gas gauge

My 98 SL500 gas gauge was blinking a few weeks ago and I replaced the gas cap with a new one. It seemed to fix the problem. Now it started to blink again. What else can cause this?
RM98SL is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 07-23-2009, 12:28 PM
BenzWorld Junior Member
 
Date registered: Jun 2009
Vehicle: 1999 SL600
Location: Boston, MA
Posts: 30
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I had the same problem with my 1999 SL600. I took it to the stealership who first changed the purge valve which did not fix the problem. Then they changed the fuel level sensor which did not fix the problem. On the third try they said it was another valve associated with the fuel tank and that to fix the car would cost about $5000 to replace a major portion of the fuel evap system. I said no thanks.

I then looked over the vacum lines and connectors to the carbon canister. Turns out it was a loose connector near one of my purge valves.

The flashing indicates a leak in the fuel and evap systems and the simpliest solution is one you can look for yourself.

I would suggest checking all the connections in the evap and canister purge lines first because this could save you lots of $$$$.

Good luck.
lawnerd1 is offline  
#3 (permalink) Old 07-23-2009, 08:45 PM
BenzWorld Member
 
Date registered: Mar 2008
Vehicle: 2004 SL 55 AMG
Location: Courtland, MN
Posts: 92
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Where are the purge valves located? I need to check this out.

I recently had my instrument cluster repaired on my 98, and now have had the fuel lights blink occasionally, along with a check engine light. I had assumed that all had not been repaired correctly for the cluster, but this makes me wonder. I have noticed that the blinking will often be tied to operating one of the power windows. The other possibility is that this occurs at idle, at a relatively low voltage situation.

2011 Chev HHR
2012 Dodge Ram 2500 Cummins
2004 SL 55 AMG
1999 BMW 328i Conv
1998 SL 500 Sport (now sold)
1994 SL 500 (now sold)
ALL the bikes now sold
Peavey is offline  
#4 (permalink) Old 07-24-2009, 07:18 AM
BenzWorld Member
 
RM98SL's Avatar
 
Date registered: Sep 2008
Vehicle: 98 SL500 , 012 CX9
Location: Upstate, South Carolina
Posts: 305
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Mine doesn’t seem to be an electrical problem after I fill up the tank and drive for awhile the blinking starts again.
I agree the location of the carbon canister and purge valves would be helpful.
RM98SL is offline  
#5 (permalink) Old 07-24-2009, 08:04 AM
BenzWorld Junior Member
 
Date registered: Jun 2009
Vehicle: 1999 SL600
Location: Boston, MA
Posts: 30
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
The carbon canister is in the trunk compartment near the antenna (driver side of car). You have to remove the carpet/lining of the entire trunk to get at it. The carbon canister has three hoses coming out of the top: one goes to the fuel injector, one connects to the fuel tank and overflow/pressure relief valve and the third goes to another pressure relief valve.

Also, if you go back there you will see the fuel tank pressure vent valve. I would make sure all the connections are tight as any leak here would be confused by the car with a loose fuel cap and give you the flashing fuel gauge light.

The purge valve is in the engine compartment. I have an SL600 which has two, I believe an SL500 will only have one purge valve. The purge valve is black and has the letters "MOT" printed on the top. You can locate the purge valve by following the vacuum line that goes from the fuel injector to the carbon canister. Check all the line connections to make sure there are no leaks. My leak was at a rubber elbow in the line. The part of the elbow that attached to the purge valve was worn, I reversed the elbow connections and it cured my problem because the worn end formed a good seal with the vacumm line (i.e. I was able to jam the vacuum line deeper into the elbow).

Someone who has a V12 S600 posted some pictures on how to find the purge valve and check for EVAP leaks in his car. Different car but same principal. You could check for that thread it will help.

Also, you can clean the purge valve with MAF cleaner. There is a thread in one of the stickies on how to do this.

Hope that helps.
lawnerd1 is offline  
#6 (permalink) Old 07-24-2009, 09:57 AM
BenzWorld Member
 
RM98SL's Avatar
 
Date registered: Sep 2008
Vehicle: 98 SL500 , 012 CX9
Location: Upstate, South Carolina
Posts: 305
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks for the info it's a big help.
RM98SL is offline  
#7 (permalink) Old 08-14-2009, 07:50 AM
BenzWorld Member
 
RM98SL's Avatar
 
Date registered: Sep 2008
Vehicle: 98 SL500 , 012 CX9
Location: Upstate, South Carolina
Posts: 305
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
I finally stopped the blinking gas gauge.
Checked all systems – charcoal canister, purge valve, hoses and connections all were
O-K. It was a damaged fuel filler tube. A new gas cap would work for only a short time and then be damaged by the filler tube. It would cut into the white cam action ring under the metal tabs. The cap wouldn’t come off (another post) and would not seal properly.
The fix - an aftermarket gas cap from Car Quest for $14.00. The damaged tube doesn’t affect the cap because there isn’t a white ring to become damaged. The rubber seal is spring loaded giving a good positive seal. No blinking gas gauge for the last two fill ups.
RM98SL is offline  
#8 (permalink) Old 05-03-2010, 01:27 PM
BenzWorld Member
 
RM98SL's Avatar
 
Date registered: Sep 2008
Vehicle: 98 SL500 , 012 CX9
Location: Upstate, South Carolina
Posts: 305
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Have to up date this post.
The blinking started again about a month after my last post. The damaged fuel filler tube was a problem, but not the cause of my blinking gas gauge.
One of the things I was doing was cleaning the purge valve. I noticed after it was cleaned the blinking stopped for a few fill ups and then start again. This was going on during the winter when I wasn't driving the car much.It would come after the car was warmed up and I was sitting in traffic at a red light for a few minutes. If there was no traffic no problem. Now I am using it daily and needed to put an end to this.
Ordered a new purge valve at Autohas, installed it.
Took at trip to Charleston SC total of 450 miles. Got caught in heavy stop and go traffic. No blinking gas gauge. Have been back a few weeks and have gone almost a thousand miles since I replaced the valve and its still good.
So far it looks like it was the purge valve. I just hope this is finally over.
RM98SL is offline  
#9 (permalink) Old 09-12-2010, 07:32 PM
BenzWorld Junior Member
 
kenjmoser's Avatar
 
Date registered: Oct 2006
Vehicle: Mercedes 93 300SD
Location: San Diego
Posts: 29
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I had the same symptoms as detailed above -- blinking fuel guage and check engine light on; thanks to the forum I quickly found the problem. The hose going from the purge value to the throttle body on the driver’s side had come off of the purge value on our v12 1998 SL600. My independant had just changed the throttle body the previous week.
kenjmoser is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Roadster Forums > R129 SL Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
blinking gas light chrisd56 W210 E-Class 7 01-05-2012 08:18 PM
When I Fill My Gas Tank the Gas Gauge Shows Empty - Why?? Schantzie240 W208 CLK Class 9 12-23-2008 04:04 PM
Blinking Fuel Gauge DAzzi R129 SL Class 4 03-02-2008 10:12 PM
Gas Alarm blinking.... sstomcat W163 M-Class 3 02-15-2007 04:52 PM
BLINKING GAS GAUGE AND CHECK ENGINE LIGHT HMCGARY W140 S-Class 0 06-03-2004 09:29 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome