ASR LIGHT STAYS ON: 1993 500SL - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 56 (permalink) Old 06-25-2009, 07:50 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Feb 2009
Vehicle: 1993 Mercedes Benz SL500
Location: Virginia
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Unhappy ASR LIGHT STAYS ON: 1993 500SL

Hello

My ASR light is on, I have checked the tires for proper air pressure and wear and they are OK. I then built the diagnostic code reader from this web site and connected to the ECU connection pins for testing the ASR circuit (socket 1: Ground) (socket 3: 12V) (socket 6: ABS/ASR output) for testing. The results were two faults: 21 flashes and 30 flashes. I have purchased the MB CD but cant find the fault code table on the CD. I did find find a fault code table on this web site and I think it's for my model car. It states 21 flashes is the Pressure Switch (A7/3s1) Charge and 30 flashes is the CAN data line to EA/CC/ISC module (N4/1). Wow, I dont have a clue what either one of those possible causes could be or where to begin. Any help into trouble shooting and solving this problem would be greatly appreciated.

Charlie
seller is offline  
Sponsored Links
Advertisement
 
post #2 of 56 (permalink) Old 06-25-2009, 09:18 PM
BenzWorld Junior Member
 
hollerbox's Avatar
 
Date registered: Nov 2007
Vehicle: 1994 SL500
Location: Alberta, Canada
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Search on 'wiring harness'...a common source of problems like this for 93-96 R129s:

PeachParts Mercedes ShopForum - View Single Post - wiring harness problem on SL600

Long story short: replace the wiring harness first and go from there.
hollerbox is offline  
post #3 of 56 (permalink) Old 06-26-2009, 07:31 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Feb 2009
Vehicle: 1993 Mercedes Benz SL500
Location: Virginia
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
ASR LIGHT 993 500 SL

Thanks, I will replace wiring harnesses, let me start researching engine harness suppliers for the best price.

Charlie
seller is offline  
post #4 of 56 (permalink) Old 09-10-2012, 09:13 PM
BenzWorld Elite
 
Bimmerman4ever's Avatar
 
Date registered: Jun 2009
Vehicle: 99 Audi A8 Quattro 4.2 & 00 E320 4M
Location: Nevada/Reno
Posts: 1,546
Mentioned: 1 Post(s)
Quoted: 17 Post(s)
Garage
It's been a while. Ever find a wire harness?

Past Euros: 91 MBZ 300TE, 91 Jaguar XJS V12 Coupe, 94 Alfa Romeo 164 LS, 80 BMW 320i, 85 BMW 528e, 86 BMW 325e, 88 BMW 325e, 88 BMW 325i Cab, 89 BMW 325ix, 91 325i Cabrio, 93 BMW 740i, 94 BMW 740iL, 95 BMW 525i, 78 Fiat Spyder 124, 98 Land Rover D1 LSE, 93 MBZ 190E 2.6, 96 MBZ C280 Sport, 93 MBZ 400E, 90 MBZ 300ce, 92 MBZ 500SL, 71 MGB-GT, 91 VW Corrado G60
Bimmerman4ever is offline  
post #5 of 56 (permalink) Old 09-11-2012, 07:51 AM
Moderator
 
bayhas's Avatar
 
Date registered: Oct 2005
Vehicle: SL55, 300SE, GL450, Daytona 955i
Location: Lincoln / Boston - MA
Posts: 10,113
Mentioned: 5 Post(s)
Quoted: 270 Post(s)
Lifetime Premium Member
Garage
Send a message via MSN to bayhas Send a message via Yahoo to bayhas
there are no suppliers for harness, you can either rebuild yours, or buy one from the dealer.

Garage:

Mercedes-Benz, W140 S Class S320 (AKA 300SE)

Mercedes-Benz, R230 SL Class SL55 (///AMG)

Mercedes-Benz, X164 GL CLass GL450

Triumph Daytona 955i

Former Mercs:
R129 SL Class SL500 (passed on) - W163 M Class ML430 Designo (for sale) - W140 S Class 500SEL(sold) - W140 S Class S320(sold) - W140 S Class S500(sold) - W140 S Class 500SEL(sold) - W201 190E 2.3(sold)
bayhas is online now  
post #6 of 56 (permalink) Old 09-11-2012, 10:05 AM
BenzWorld Elite
 
Bimmerman4ever's Avatar
 
Date registered: Jun 2009
Vehicle: 99 Audi A8 Quattro 4.2 & 00 E320 4M
Location: Nevada/Reno
Posts: 1,546
Mentioned: 1 Post(s)
Quoted: 17 Post(s)
Garage
Any idea on wire size ?


Past Euros: 91 MBZ 300TE, 91 Jaguar XJS V12 Coupe, 94 Alfa Romeo 164 LS, 80 BMW 320i, 85 BMW 528e, 86 BMW 325e, 88 BMW 325e, 88 BMW 325i Cab, 89 BMW 325ix, 91 325i Cabrio, 93 BMW 740i, 94 BMW 740iL, 95 BMW 525i, 78 Fiat Spyder 124, 98 Land Rover D1 LSE, 93 MBZ 190E 2.6, 96 MBZ C280 Sport, 93 MBZ 400E, 90 MBZ 300ce, 92 MBZ 500SL, 71 MGB-GT, 91 VW Corrado G60
Bimmerman4ever is offline  
post #7 of 56 (permalink) Old 09-11-2012, 10:14 AM
Moderator
 
bayhas's Avatar
 
Date registered: Oct 2005
Vehicle: SL55, 300SE, GL450, Daytona 955i
Location: Lincoln / Boston - MA
Posts: 10,113
Mentioned: 5 Post(s)
Quoted: 270 Post(s)
Lifetime Premium Member
Garage
Send a message via MSN to bayhas Send a message via Yahoo to bayhas
there is a about 70 wires in the harness, different sizes, 16-12AWG, I wouldnt recommend testing with your own, as most jacks require some experience to open properly, one mistake, and your car is a sitting duck...

contact BBA for throttle rebuild, and Alex for upper engine harness rebuild.

Garage:

Mercedes-Benz, W140 S Class S320 (AKA 300SE)

Mercedes-Benz, R230 SL Class SL55 (///AMG)

Mercedes-Benz, X164 GL CLass GL450

Triumph Daytona 955i

Former Mercs:
R129 SL Class SL500 (passed on) - W163 M Class ML430 Designo (for sale) - W140 S Class 500SEL(sold) - W140 S Class S320(sold) - W140 S Class S500(sold) - W140 S Class 500SEL(sold) - W201 190E 2.3(sold)
bayhas is online now  
post #8 of 56 (permalink) Old 09-11-2012, 10:17 AM
BenzWorld Elite
 
Bimmerman4ever's Avatar
 
Date registered: Jun 2009
Vehicle: 99 Audi A8 Quattro 4.2 & 00 E320 4M
Location: Nevada/Reno
Posts: 1,546
Mentioned: 1 Post(s)
Quoted: 17 Post(s)
Garage
Quote:
Originally Posted by bayhas View Post
there is a about 70 wires in the harness, different sizes, 16-12AWG, I wouldnt recommend testing with your own, as most jacks require some experience to open properly, one mistake, and your car is a sitting duck...

contact BBA for throttle rebuild, and Alex for upper engine harness rebuild.

Is it typically the ETA that deteriorates or the main harness that goes first?

Past Euros: 91 MBZ 300TE, 91 Jaguar XJS V12 Coupe, 94 Alfa Romeo 164 LS, 80 BMW 320i, 85 BMW 528e, 86 BMW 325e, 88 BMW 325e, 88 BMW 325i Cab, 89 BMW 325ix, 91 325i Cabrio, 93 BMW 740i, 94 BMW 740iL, 95 BMW 525i, 78 Fiat Spyder 124, 98 Land Rover D1 LSE, 93 MBZ 190E 2.6, 96 MBZ C280 Sport, 93 MBZ 400E, 90 MBZ 300ce, 92 MBZ 500SL, 71 MGB-GT, 91 VW Corrado G60
Bimmerman4ever is offline  
post #9 of 56 (permalink) Old 09-11-2012, 10:19 AM
Moderator
 
bayhas's Avatar
 
Date registered: Oct 2005
Vehicle: SL55, 300SE, GL450, Daytona 955i
Location: Lincoln / Boston - MA
Posts: 10,113
Mentioned: 5 Post(s)
Quoted: 270 Post(s)
Lifetime Premium Member
Garage
Send a message via MSN to bayhas Send a message via Yahoo to bayhas
both, although the ETA is a tad bit more insulated, but the upper engine harness does not affect the ASR/ABS operation, but rather, causes the car to run rough...

Garage:

Mercedes-Benz, W140 S Class S320 (AKA 300SE)

Mercedes-Benz, R230 SL Class SL55 (///AMG)

Mercedes-Benz, X164 GL CLass GL450

Triumph Daytona 955i

Former Mercs:
R129 SL Class SL500 (passed on) - W163 M Class ML430 Designo (for sale) - W140 S Class 500SEL(sold) - W140 S Class S320(sold) - W140 S Class S500(sold) - W140 S Class 500SEL(sold) - W201 190E 2.3(sold)
bayhas is online now  
post #10 of 56 (permalink) Old 09-11-2012, 10:26 AM
BenzWorld Elite
 
Bimmerman4ever's Avatar
 
Date registered: Jun 2009
Vehicle: 99 Audi A8 Quattro 4.2 & 00 E320 4M
Location: Nevada/Reno
Posts: 1,546
Mentioned: 1 Post(s)
Quoted: 17 Post(s)
Garage
Quote:
Originally Posted by bayhas View Post
both, although the ETA is a tad bit more insulated, but the upper engine harness does not affect the ASR/ABS operation, but rather, causes the car to run rough...
I see.

I tried to clear the ABS/ASR light by a couple methods I read.
Grounding pin 4 with 1 (38 pin) for 6-8 seconds ignition position 2
off 5 seconds, then pos 2 for 10 seconds then start

also the removal of the ground battery wire then shorting with a screw driver
to the positive lead

Neither worked. So I'm going to make or buy a simple 3 wire LED code reader and see if I can pull the codes and clear them out.

Instructions anywhere to make one?

(by the way same year 500SL a 93 with ABS/ASR on and top problems)

Bimmerman4ever is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Roadster Forums > R129 SL-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    ASR LIGHT 1993 500SL seller General Mercedes-Benz 5 07-02-2009 10:06 PM
    1992 500SL ABS/ASR light stays on at start-up 92sl500 R129 SL-Class 10 11-11-2008 04:45 AM
    ASR and ABS indicator light stays on, on my 93 SL500 Strick9 General Mercedes-Benz 0 10-17-2008 04:06 PM
    92 500SL ASR Light charris130 R129 SL-Class 1 09-19-2007 06:45 AM
    1993 600 sl asr light peter hamlett R129 SL-Class 0 08-06-2003 09:13 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome