ABS / BAS & ESP WARNING LAMPS ON - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Roadster Forums > R129 SL Class
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-05-2008, 06:25 PM   #1 (permalink)
BenzWorld Junior Member
 
Pigzmickey's Avatar
 
Date registered: Apr 2005
Vehicle: SL 600
Location: Gold Coast, Australia. Formerly Bristol, UK.
Posts: 45
ABS / BAS & ESP WARNING LAMPS ON

Hi all,

I wondered if anyone here has an idea of what is going on with my dash unit...

I did a little work under the rear seat on the weekend, I had to disconnect the roof control unit so I removed the appropriate fuses to remove the power to this unit first.

However now I have the above lights on, on the dash, right from ignition start. I have tried the steering sensor reset (turn left & right) but no change, I tried removing the battery just incase but no change.

Running out of ideas here...

Anyone???
Pigzmickey is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-05-2008, 07:10 PM   #2 (permalink)
BenzWorld Member
 
crashr129's Avatar
 
Date registered: Dec 2007
Posts: 87
does your battery have the correct voltage? if not charge or replace if necessary ..
__________________
96 sl600 77k
92 ninja600 18k
00 s10 278k
06 m109R 16k
69 chevelle 77k (sold)
-MR. PROC- 22yr
crashr129 is offline   Reply With Quote
Old 02-06-2008, 01:15 AM   #3 (permalink)
BenzWorld Elite
 
msbarsi's Avatar
 
Date registered: May 2006
Vehicle: 2000 Obsidian Black Metallic Mercedes SL 320 V6
Location: Northern Italy near Milan
Posts: 4,478
Send a message via Skype™ to msbarsi
Hi Pigzmickey did you try the sync procedure ? Since you disconnected the roof control unit it might be needed.

Hope it helps.

Cheers.
msbarsi is offline   Reply With Quote
Old 02-08-2008, 01:08 PM   #4 (permalink)
BenzWorld Elite
 
Date registered: Jan 2004
Vehicle: SL500, 300SL, 500SL
Location: Atlanta, USA
Posts: 2,165
I would check the fuses mounted in the top of the base module because it supplies power to the ESP module. If those are okay, then I would read diagnostic codes. Since this car is newer than '95 a Mercedes-specific code scanner is required. A Mercedes repair shop can do it, or you can get a Carsoft compatible scanner on eBay for about $100. I have two of these, and while they don't do everything they are advertised to do, they work great.
__________________
Many used parts available from a '92 SL. Email or PM for more information
bobterry99 is offline   Reply With Quote
Old 05-18-2008, 04:25 PM   #5 (permalink)
BenzWorld Member
 
Rocco Vespe's Avatar
 
Date registered: Dec 2007
Vehicle: 1999 SL500
Location: New Jersey
Posts: 60
Question ABS,BAS,and ESP lights all at once

1999 SL500 - All three lights came on at once. Any idea what this means ? Any suggestions on how to fix.
Thanks,
Rocco
1999 sl500
1988 xjs convertible
1982 xjs
2001 xj8
Rocco Vespe is offline   Reply With Quote
Old 05-18-2008, 06:17 PM   #6 (permalink)
BenzWorld Veteran
 
SunGuy61's Avatar
 
Date registered: Mar 2005
Vehicle: 1987 560SL Gone but not forgotten! & 1999 SL500 For Now
Location: Bradenton, FL
Posts: 716
Send a message via AIM to SunGuy61
Rocco,
When this happened to me, the cause was low voltage output from the battery. My situation was my tech was doing a 'stress test' of sorts on my battery when in for 60K mi service and drained it a bit. After I ran the car for 20 minutes or so, stopped, and restarted awhile later, all the lights (ABS, ESP & BAS) were out as the battery had returned to full charge.

Were you doing anything with the car just prior to these warning lights coming on? Putting the top up/down with engine off? If not, this could also be a sign of a weakening battery and you should have it tested.

Bob
SunGuy61 is offline   Reply With Quote
Old 05-19-2008, 12:10 AM   #7 (permalink)
BenzWorld Elite
 
Date registered: Jan 2004
Vehicle: SL500, 300SL, 500SL
Location: Atlanta, USA
Posts: 2,165
Also might be a blown fuse in the Base Module. An advanced search on my username and Base Module will show a picture and more info.
bobterry99 is offline   Reply With Quote
Old 08-15-2009, 11:23 AM   #8 (permalink)
BenzWorld Member
 
greygirl's Avatar
 
Date registered: Mar 2009
Vehicle: 1998 Mercedes Benz SL500,1989 Chrysler New Yorker Landau(30000 miles),2002 Dodge Dakota SLT,2010 DoX
Location: Winnipeg,MB,CA
Posts: 58
Bas and ABS lights

Hi Everyone
I have been having trouble with the BAS and ABS coming on intermittently. They will come on and stay on for a day and then go off and are good for 3 or 4 days. I have taken it to the dealers and they have replaced the Steering Positioning Sensor and the Clockwork Spring. They have had the car for a week now and still can't find the problem. Has anyone got any ideas as to what the problem may be or where to look for the cause.
The car is a 1998 SL 500 with approximately 40,000 miles. Thanks for the help

Greygirl
greygirl is offline   Reply With Quote
Old 08-15-2009, 01:22 PM   #9 (permalink)
BenzWorld Member
 
Frenchy's Avatar
 
Date registered: Sep 2007
Vehicle: W201 190E 09/1992 & C219 CLS 500 01/2005 & W202 C250TD 10/1997(Sold) & R129 300SL24 09/1989
Location: LILLE (France)
Posts: 69
Hi,

Maybe this problem is the first one before your Instrument Cluster goes mad...

2 members here in France had the same problems...their IC starts blinking sometimes, then they lose power and so on...

On facelift models, there is no more OVP relay, but some calculators & Data BUS connected to the IC.

Regards,

Frenchy.
Frenchy is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Roadster Forums > R129 SL Class

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Topic Author Forum Replies Last Post
Warning Lamp Trifecta-ESP, BAS, ABS SunGuy61 R129 SL Class 63 03-22-2011 05:12 PM
abs and bas esp warning lights rxphiler W208 CLK Class 9 10-29-2007 10:33 AM
ESP/BAS & ABS warning lights in A-140 johnmanoj1 W168 A-Class 3 08-30-2006 09:13 AM
ABS and BAS/ESP warning lights ON?? koosha R170 SLK Class 5 02-22-2005 08:55 AM
ABS/ESP/BAS warning light...update Syd R170 SLK Class 2 04-28-2003 12:29 PM


All times are GMT -7. The time now is 03:47 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.