My SL600 Hard Top Is not working - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Roadster Forums > R129 SL Class
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-25-2006, 01:26 PM   #1 (permalink)
BenzWorld Member
 
mame9999's Avatar
 
Date registered: Oct 2006
Posts: 287
My SL600 Hard Top Is not working

Hi guys suddenly I need to open my hard top but it is not responding


my car is 1993 SL600


thanks
mame9999 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-25-2006, 02:23 PM   #2 (permalink)
BenzWorld Member
 
Date registered: Apr 2006
Posts: 77
hi mame how are you? i hope you enjoy your new sl.. any way check the hyd fluid in the pump and the fueses
feras is offline   Reply With Quote
Old 12-25-2006, 06:05 PM   #3 (permalink)
BenzWorld Elite
 
Date registered: Jan 2004
Vehicle: SL500, 300SL, 500SL
Location: Atlanta, USA
Posts: 2,165
To remove the hard top you have to operate the switch within 10 seconds of turning the key on. Also, I think the windows have to be down or the doors have to be open.
bobterry99 is offline   Reply With Quote
Old 12-26-2006, 08:09 AM   #4 (permalink)
BenzWorld Member
 
mame9999's Avatar
 
Date registered: Oct 2006
Posts: 287
Quote:
Originally Posted by feras
hi mame how are you? i hope you enjoy your new sl.. any way check the hyd fluid in the pump and the fueses

Hala feras How r u doing dear i need to ask you where is the Hardtop fuses located? and hyd fluid is ok but it is not relese I open it manualy and I need to use soft top but not working


thanks for your replay
mame9999 is offline   Reply With Quote
Old 12-26-2006, 08:13 AM   #5 (permalink)
BenzWorld Member
 
mame9999's Avatar
 
Date registered: Oct 2006
Posts: 287
Quote:
Originally Posted by bobterry99
To remove the hard top you have to operate the switch within 10 seconds of turning the key on. Also, I think the windows have to be down or the doors have to be open.

thank you for your replay and I will try today your advice


yours truly

Mohammed
mame9999 is offline   Reply With Quote
Old 12-26-2006, 02:34 PM   #6 (permalink)
BenzWorld Member
 
Date registered: Apr 2006
Posts: 77
hi mohammed how are u... i think the fuses are in the trunk but does your soft top works or nothing at all? do u hear the pump ? it could be a microswitch out of adjustment or pump relay not working or u got problem with the control unit it self but i hope not. by the way i wanna ask u have you seen sl used parts in your area? or dammam because i'm looking for some parts .
feras is offline   Reply With Quote
Old 12-29-2006, 03:51 PM   #7 (permalink)
BenzWorld Member
 
mame9999's Avatar
 
Date registered: Oct 2006
Posts: 287
Quote:
Originally Posted by feras
hi mohammed how are u... i think the fuses are in the trunk but does your soft top works or nothing at all? do u hear the pump ? it could be a microswitch out of adjustment or pump relay not working or u got problem with the control unit it self but i hope not. by the way i wanna ask u have you seen sl used parts in your area? or dammam because i'm looking for some parts .
hi feras I am v. good and u ? yes i dont hear any noise while press the button and my soft top is not working as well, and roll bar not working too, today I opened hard top and I use soft top manuly can you help on that ? I think problem is electric or some thing else

what parts you are looking for let me to try to help you

yours

Mohammed
mame9999 is offline   Reply With Quote
Old 12-31-2006, 02:28 PM   #8 (permalink)
BenzWorld Member
 
Date registered: Apr 2006
Posts: 77
hi mohammed how are u.. in fact i'm looking for hard top seals which is around the windows both sides. if you can find it please tell me . by the way u need to chack few things for your soft top.. does the soft top switch flashs you you torn the key on? if it flashs it means there is a power to the control unit . does your windows moves when u operate the switch? if it operates the windows it means the control unit is reciveing the signal from the switch and you need to check the pump, fuses in the trunk and the relay on the pump. . if your switch flashes you can account the flashes to find which code does the control unit gives. every code is related to a microswitch in the system. check these things and tell us what u got... good luck.....

Last edited by feras; 12-31-2006 at 02:47 PM.
feras is offline   Reply With Quote
Old 01-02-2007, 07:08 AM   #9 (permalink)
BenzWorld Member
 
mame9999's Avatar
 
Date registered: Oct 2006
Posts: 287
Quote:
Originally Posted by feras
hi mohammed how are u.. in fact i'm looking for hard top seals which is around the windows both sides. if you can find it please tell me . by the way u need to chack few things for your soft top.. does the soft top switch flashs you you torn the key on? if it flashs it means there is a power to the control unit . does your windows moves when u operate the switch? if it operates the windows it means the control unit is reciveing the signal from the switch and you need to check the pump, fuses in the trunk and the relay on the pump. . if your switch flashes you can account the flashes to find which code does the control unit gives. every code is related to a microswitch in the system. check these things and tell us what u got... good luck.....

hi feras thank you very much for your kind advice, and i am looking for your parts around, and need to ask you about some thing i don't get it (if your switch flashes you can account the flashes to find which code does the control unit gives. every code is related to a microswitch in the system)

and my red switch is flashing but windows is not open and roll bar is not working up or down.

I need more of your help Mr. Feras


your replay will be highly appreceated


Mohammed
mame9999 is offline   Reply With Quote
Old 01-02-2007, 07:40 AM   #10 (permalink)
BenzWorld Elite
 
Date registered: Jan 2004
Vehicle: SL500, 300SL, 500SL
Location: Atlanta, USA
Posts: 2,165
Mohammed, I would read codes from the soft top controller, erase them, and then retry the top. If it still doesn't work, read codes again and post them back in the forum.

The procedure for reading and erasing codes is described here: http://www.benzworld.org/forums/r129...pre-94-a.html?. Your car has a 38-pin diagnostic connector, and #21 is for the top controller.
bobterry99 is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Roadster Forums > R129 SL Class

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Topic Author Forum Replies Last Post
Hard top / Soft top and Roll Bar Dash Lights Staying On sfguy100 R129 SL Class 4 01-06-2007 01:42 AM
My SL600 soft top won't open mame9999 R129 SL Class 2 11-09-2006 01:27 PM
Hard top Hoist store your hard top from your ceiling Steve1g R/C107 SL/SLC Class 5 05-12-2006 05:45 PM
hard top for electric soft top g's brabus g36 G-Class 2 12-15-2004 05:46 PM
Crossfire cabriolet, soft top, no room for a hard top. SteveL R170 SLK Class 1 01-24-2002 05:23 PM


All times are GMT -7. The time now is 06:25 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.