1994 SL500 window won't go up. - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Roadster Forums > R129 SL Class
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-20-2004, 07:09 AM   #1 (permalink)
BenzWorld Junior Member
 
Date registered: Jul 2004
Posts: 7
1994 SL500 window won't go up.

I put my passenger window down last night and when I went to put it up it started and then stopped. I then put it down and it went down. Now it won't move at all. I can hear the motor running but the window does not move. Anyone have any suggestions on what could be wrong and how to go about fixing it.

Thanks[:D]
samtbenz is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-21-2004, 08:45 AM   #2 (permalink)
BenzWorld W140 Host
 
zeaq's Avatar
 
Date registered: Aug 2003
Vehicle: W140 S 320 L & R129 500SL
Location: Qatar & Brunei
Posts: 1,879
Lifetime Premium Member
Send a message via MSN to zeaq Send a message via Yahoo to zeaq
RE: 1994 SL500 window won't go up.

Maybe changing the regulator.....My S320 has the same problem as Ur car....I Change the regulator and all problem solve....[:)]
zeaq is offline   Reply With Quote
Old 08-23-2004, 02:36 AM   #3 (permalink)
BenzWorld Member
 
Date registered: Jun 2003
Vehicle: Mercedes 300 SL-24
Location: Portugal
Posts: 111
RE: 1994 SL500 window won't go up.

I had the same problem. I had the window engine opened and cleaned: it has an POM made gear that was filled with rust from the engine cover (maybe it got some moisture).
After that it works ok. Probably you don't need to replace the engine.

Jorge
'91 300 SL-24
AJSM is offline   Reply With Quote
Old 08-23-2004, 12:03 PM   #4 (permalink)
BenzWorld Junior Member
 
Date registered: Aug 2004
Vehicle: 500SL
Posts: 21
Send a message via MSN to cbradlea
RE: 1994 SL500 window won't go up.

I recently had the same problem one of the bolts holding the window was lose. That caused my window to go up slow and sometime not close. Tightened the bolt and like magic it worked again.
cbradlea is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Roadster Forums > R129 SL Class

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 06:35 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.