1994 SL500 window won't go up. - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 08-20-2004, 07:09 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Jul 2004
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
1994 SL500 window won't go up.

I put my passenger window down last night and when I went to put it up it started and then stopped. I then put it down and it went down. Now it won't move at all. I can hear the motor running but the window does not move. Anyone have any suggestions on what could be wrong and how to go about fixing it.

Thanks[:D]
samtbenz is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 08-21-2004, 08:45 AM
BenzWorld W140 Host
 
zeaq's Avatar
 
Date registered: Aug 2003
Vehicle: W140 S 320 L & R129 500SL
Location: Qatar & Brunei
Posts: 1,918
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Lifetime Premium Member
Send a message via MSN to zeaq Send a message via Yahoo to zeaq
RE: 1994 SL500 window won't go up.

Maybe changing the regulator.....My S320 has the same problem as Ur car....I Change the regulator and all problem solve....[:)]
zeaq is offline  
post #3 of 4 (permalink) Old 08-23-2004, 02:36 AM
BenzWorld Member
 
Date registered: Jun 2003
Vehicle: Mercedes 300 SL-24
Location: Portugal
Posts: 111
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
RE: 1994 SL500 window won't go up.

I had the same problem. I had the window engine opened and cleaned: it has an POM made gear that was filled with rust from the engine cover (maybe it got some moisture).
After that it works ok. Probably you don't need to replace the engine.

Jorge
'91 300 SL-24
AJSM is offline  
post #4 of 4 (permalink) Old 08-23-2004, 12:03 PM
BenzWorld Junior Member
 
Date registered: Aug 2004
Vehicle: 500SL
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via MSN to cbradlea
RE: 1994 SL500 window won't go up.

I recently had the same problem one of the bolts holding the window was lose. That caused my window to go up slow and sometime not close. Tightened the bolt and like magic it worked again.
cbradlea is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Roadster Forums > R129 SL-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    User Tag List

    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome