Speedometer cable or odometer noise? - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 12-30-2001, 05:40 PM
BenzWorld Newbie
 
Date registered: Dec 1998
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Speedometer cable or odometer noise?

I'm experiencing a whining noise with my '73 450SL. Starts at about 45 mph. At first I was inclined to think it was the speedometer cable, but not sure. Noise kicks in pretty consistently at about 45, won't stop till car is almost at a dead stand still. The trip odometer doesn't work any more but will not reset to zero. Car has 117K on it. I'm pretty confident it's the cable due to vibrations felt when putting hand against face of speedometer. I figured after the holidays I'd look into the problem but hopefully someone may have had the same problem. Any answers? DP
Guest (MBNZ) is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 02-06-2002, 11:01 AM
BenzWorld Newbie
 
Date registered: Dec 1998
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Re: Speedometer cable or odometer noise?

i have a 76 slc and it did the same thing when it was super cold outside -- lemme know what you figure out, ok?
Guest (MBNZ) is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Roadster Forums > R/C107 SL/SLC Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome