WTF is wrong with the 190E? - Page 3 - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #21 of 59 (permalink) Old 05-12-2009, 04:12 PM
Administratoris Emeritus
 
GeeS's Avatar
 
Date registered: Aug 2002
Vehicle: 2021 SL770
Location: Fountain Hills, AZ
Posts: 45,217
Mentioned: 2 Post(s)
Quoted: 751 Post(s)
Quote:
Originally Posted by drewprof View Post
What clicking sound? I don't remember that!
This is the first time I ever heard this buzzing sound inside the cabin, behind the cluster once I get the engine going by keeping the throttle down. The car wouldn't start otherwise.
I read it on another forum, as I recall.

"If spending money you don't have is the height of stupidity, borrowing money to give it away is the height of insanity." -- anon
GeeS is offline  
Sponsored Links
Advertisement
 
post #22 of 59 (permalink) Old 05-12-2009, 04:17 PM Thread Starter
DP
Moderator
 
DP's Avatar
 
Date registered: Aug 2002
Vehicle: 190E, 400E, SLK350
Location: Chesapeak Bay
Posts: 64,451
Mentioned: 2 Post(s)
Quoted: 1120 Post(s)
Lifetime Premium Member
(Thread Starter)
Quote:
Originally Posted by GermanStar View Post
I read it on another forum, as I recall.
I have been in so many that it's not even funny anymore. I still don't recall a clicking sound, but maybe it was in reference to valve noises, I don't know, but I do I know is that this LOUD buzzing sound inside the dashboard is a first.
DP is offline  
post #23 of 59 (permalink) Old 05-12-2009, 04:24 PM
BenzWorld Elite
 
Date registered: Feb 2007
Vehicle: 300SD
Location: Florida, USA
Posts: 11,191
Mentioned: 0 Post(s)
Quoted: 62 Post(s)
Most people who have older cars have problems with them. I too like to fix everything myself but I draw a line when I spend days troubleshooting something with no results, or have a job that requires a high lift and plenty of time. I too have been burned by incompetent mechanics, including the ones at our local Mercedes dealership. I took my 300SD to them because the A/C compressor would not come on. After several hours of trobleshooting I was told that I needed the auto temperature controller box for $ 1,200! They charged me $ 180 for the diagnosis and I left. I bought the same controller for $ 230 from an aftermarket source, installed it and nothing! Over $ 400 down the drain and no results! So I stated troubleshooting the system myself. I found the problem in less than an hour. It was the thermostatic switch in series with the main A/C switch. Very clearly shown on the schematic. All I had to do was jumper the switch out of the circuit and the A/C compressor immediately came on. The replacement switch cost less than $ 50 and it took about an hour to install it.

Last edited by p100; 05-12-2009 at 04:28 PM.
p100 is offline  
post #24 of 59 (permalink) Old 05-12-2009, 04:26 PM
Administratoris Emeritus
 
GeeS's Avatar
 
Date registered: Aug 2002
Vehicle: 2021 SL770
Location: Fountain Hills, AZ
Posts: 45,217
Mentioned: 2 Post(s)
Quoted: 751 Post(s)
Quote:
Originally Posted by drewprof View Post
I have been in so many that it's not even funny anymore. I still don't recall a clicking sound, but maybe it was in reference to valve noises, I don't know, but I do I know is that this LOUD buzzing sound inside the dashboard is a first.
No, is wasn't coming from under the hood, it was closer.

"If spending money you don't have is the height of stupidity, borrowing money to give it away is the height of insanity." -- anon
GeeS is offline  
post #25 of 59 (permalink) Old 05-12-2009, 04:28 PM Thread Starter
DP
Moderator
 
DP's Avatar
 
Date registered: Aug 2002
Vehicle: 190E, 400E, SLK350
Location: Chesapeak Bay
Posts: 64,451
Mentioned: 2 Post(s)
Quoted: 1120 Post(s)
Lifetime Premium Member
(Thread Starter)
Quote:
Originally Posted by GermanStar View Post
No, is wasn't coming from under the hood, it was closer.
Well I did hear a hissing sound from the heating unit but that's not what I hear now.
DP is offline  
post #26 of 59 (permalink) Old 05-12-2009, 04:31 PM
Administratoris Emeritus
 
GeeS's Avatar
 
Date registered: Aug 2002
Vehicle: 2021 SL770
Location: Fountain Hills, AZ
Posts: 45,217
Mentioned: 2 Post(s)
Quoted: 751 Post(s)
No, you seemed to be describing a clicking noise as if a relay had failed. You don't remember? No wonder you can't fix it.

"If spending money you don't have is the height of stupidity, borrowing money to give it away is the height of insanity." -- anon
GeeS is offline  
post #27 of 59 (permalink) Old 05-12-2009, 04:31 PM
BenzWorld Elite
 
Date registered: Feb 2007
Vehicle: 300SD
Location: Florida, USA
Posts: 11,191
Mentioned: 0 Post(s)
Quoted: 62 Post(s)
Quote:
Originally Posted by drewprof View Post
Well I did hear a hissing sound from the heating unit but that's not what I hear now.
A 5 ft rattlesnake hidden in the engine compartment?
p100 is offline  
post #28 of 59 (permalink) Old 05-12-2009, 04:35 PM Thread Starter
DP
Moderator
 
DP's Avatar
 
Date registered: Aug 2002
Vehicle: 190E, 400E, SLK350
Location: Chesapeak Bay
Posts: 64,451
Mentioned: 2 Post(s)
Quoted: 1120 Post(s)
Lifetime Premium Member
(Thread Starter)
Quote:
Originally Posted by GermanStar View Post
No, you seemed to be describing a clicking noise as if a relay had failed. You don't remember? No wonder you can't fix it.
Ah I remember! That's a single click! That happens when the engine shuts off. It's not in the cabin, it's the fuel pump that does that.
DP is offline  
post #29 of 59 (permalink) Old 05-12-2009, 04:49 PM
Lifetime Premium Member
 
Shane's Avatar
 
Date registered: Aug 2002
Vehicle: Taking my time on my ride
Location: north American continent
Posts: 41,805
Mentioned: 6 Post(s)
Quoted: 1801 Post(s)
Lifetime Premium Member
Tell us again what the thing does when it stalls and when you can restart it.
Shane is offline  
post #30 of 59 (permalink) Old 05-12-2009, 04:53 PM Thread Starter
DP
Moderator
 
DP's Avatar
 
Date registered: Aug 2002
Vehicle: 190E, 400E, SLK350
Location: Chesapeak Bay
Posts: 64,451
Mentioned: 2 Post(s)
Quoted: 1120 Post(s)
Lifetime Premium Member
(Thread Starter)
Quote:
Originally Posted by Shane View Post
Tell us again what the thing does when it stalls and when you can restart it.
Well now it's screwed because I have the air mixture and EHA adjustments all off. Whatever I describe as the original stalling scenarios probably don't apply right now, specially with this buzzer business that sounds like a warning device of some sort.
Anyway, before I tinkered with the car, the car would stall randomly when I come to a stop such as a red light. It would also stall at start up.
DP is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Off-Topic

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
WTF is wrong with this country? Marsden Off-Topic 19 02-09-2009 03:27 PM
my 190e top is 75mph.WTF? Illan W201 190-Class 22 03-04-2008 08:41 PM
WTF?! Wrong Green Filters for my CLK55 Airbox ?!?! deyainrdy4ds C208/A208 CLK-Class 7 03-02-2007 07:59 AM
SCAM MERCEDES BENZ DEALERS not giving LOANERS ANYMORE ? WTF IS WRONG WITH THAT ? max_benz W203 C-Class 19 02-02-2007 12:40 AM
SCAM MERCEDES BENZ DEALERS not giving LOANERS ANYMORE ? WTF IS WRONG WITH THAT ? max_benz Off-Topic 26 01-24-2007 03:06 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome