Problems - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 12-14-2005, 11:21 AM Thread Starter
BenzWorld Junior Member
REDSL55AMG's Avatar
Date registered: Sep 2005
Vehicle: sl55amg-
Location: spain
Posts: 13
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via Yahoo to REDSL55AMG
(Thread Starter)

Can anyone help me?
I have owened an SL55amg for over year now and I have had nothing apart from problems with my car?
Last repair bill was 3500euros, I have complained to the mercedes garage about this but they refuse to pay for any of the bills, so far in the year I have had the car I have spent over 10000euros just on repairs.
REDSL55AMG is offline  
Sponsored Links
post #2 of 5 (permalink) Old 12-14-2005, 09:18 PM
worst mod in BW history
ThrillKill's Avatar
Date registered: Apr 2005
Vehicle: ML CLK Iridescent Hyundai Accent lol,GoPed Freightshaker & Volvo semi's, c'mawn?
Location: Chicago
Posts: 27,762
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Lifetime Premium Member
RE: Problems

1. Your in the racing forum.
2. Please state the make year of the car.
3. You'll have to elaborate. What were the problems and the fixes?

Post this in the R230 SL Class forum. Good luck.

ThrillKill is offline  
post #3 of 5 (permalink) Old 12-29-2005, 07:47 AM Thread Starter
BenzWorld Junior Member
REDSL55AMG's Avatar
Date registered: Sep 2005
Vehicle: sl55amg-
Location: spain
Posts: 13
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via Yahoo to REDSL55AMG
(Thread Starter)
RE: Problems

Make: SL55AMG Year 2002
Problems: I have had the car since Sep2004 bought it with 1okm on the clock, I have had a constant problem with the engine light I think it is called the ECU light, which indicates there is a problem somewhere, when I have taken the car in for Diagnostics, they havent been able to fine anything and they have reset it, after two days the light would come on again. I had the lights come on for over heating, automatic shutdown and this was in a car park(very embarassing), then after 2 hours it was okay. After one of the lights did not work.

About 4 weeks later another malfunction warning this time it was the alternator. Automatic shutdown again, this time I had to get towed away to the garage.They replaced the alternator. The light came on agai after a few days.
About 4-6weeks later again, I had left the car in the car park was I was travelling for 5days, came back and this time the car would not work as it did not recognize the keylessGo or the keys. Again the car got towed away to another garage and they changed the locking ignition system< big bill
The light came on again after about two weeks , took it to a garage and they done the diagnostic and nothing came up. Reset the car and no light.
2 Weeks later light came on again, took it to a garage and nothing again. Reset and off we go.
Few days later light came on again, and I didnt do anything about it and nothing happened.
Around May while I went on Holiday with the car, I had malfunctions this time with the OIL system and the brake system, warning lights and automatic shutdown. But turn the car off and turn it on again after 2 minutes and nothing.This happened about 3times.
A few weeks later the Oil light problems again, took it for a service and they done the whole service and took care of the oil problem.Replaced the parts and everything>expensive
Few days later the light again, took a to agarage and this time they fixed a few things which i think also included the spark plugs and the catalytic convertor(i think I live in spain now and my spanish is not vey good). after that the car drove beautifully, it felt really good and there did not seem to be any problems.
2-3 weeks later I drove to Uk with the car and took it a speciliast to have some performance upgrades. after they done the work the light came on again, and they could not find what the fault was.
2 days later the light for the aslternator came on again and we replaced the alternator>expensive
Drove the car and it was fine, I was getting ready to travel back to spain and took the car to a car wash and it got stuck in park and we could not move the car, we tried and tried for about 2 hours the it just clicked into Drive. Drove the car home and had mercedes come around the house where they replaced the gear lever system>expensive
Drove the car back to sapin the next days and the engine light came on again this time supportted by five other 5 other malfunctions which included the brake systems , hand brake etc...
This would happen every other day, took the car in to the garage again and this time they spent a week looking for faults and they replaced something for the right hand side suspension and the boot air locking system.> very very expensive this time.
they also tried to get mercedes head office to pay for the repairs and they refused.
I drove the car back home two days later and the engine light has come up again.
And now I sit here and I just dont know what to do? therefore can any one help me?
REDSL55AMG is offline  
post #4 of 5 (permalink) Old 02-05-2006, 07:47 PM
BenzWorld Member
BenzBoy2006's Avatar
Date registered: Feb 2006
Posts: 111
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via AIM to BenzBoy2006
RE: Problems

Wow for that kind of money you mise well buy your own diagnostics tester and just plug it in every time you see the light and if it does come on and there is no problem disconnect the battery and that should reset the ECU.
BenzBoy2006 is offline  
post #5 of 5 (permalink) Old 07-25-2006, 11:48 AM
BenzWorld Junior Member
Date registered: Jul 2006
Posts: 8
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I would of burned it by now.
benzinoc32 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Mercedes-Benz Motorsports & Racing

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome