ESP failed to stabalize car - Page 4 - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #31 of 32 (permalink) Old 02-23-2010, 07:14 AM
Outstanding Contributor
eric242340's Avatar
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,078
Mentioned: 3 Post(s)
Quoted: 283 Post(s)
Originally Posted by Frost View Post
Hi Cancer,

I agree with you 100% and I'm sure I've learned my lesson well that night. I agree that I was probably going too fast but at the time it surely didn't feel like it and that's what maybe caught me off guard that night. But after that, I'm sure it's something to keep in mind the next time I drive in the rain.
Nice to see you are thinking about it and taking it seriously Well done sir.


"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline  
Sponsored Links
post #32 of 32 (permalink) Old 02-26-2010, 09:40 PM
BenzWorld Member
Date registered: Aug 2006
Posts: 52
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
ye, some1 already prolly mentioned here - just accelerate slightly and steer counter-wise with final position as wheels straight, NEVER BRAKE VIOLENTLY when you feel skidding. I know it may feel psychologically wrong thing to do - but trust me, we all went trough that and that's the proper way of advanced driving and getting out of dangerous skid situation. Look for advanced or aggressive driving videos - amazing stuff - the more you know the better you are out there on the road

BTW - Good to see you manage not to hit anything or damage yourself
I remember once with my 1986 W124 300E when i turned 50mph into wet pothole and had to manage my babe (she had no ABS or EPS )) back to safety...

You were going to fast with C class - trust me you you may want to go somehow fast with maybe S classe, but not your C240 - its just not made or optimized for fast velocity.
unSobill320 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > MB Safety & Testimonials

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Car failed Smog. Any ideas? amejia3620 W202 C36 AMG, C43 AMG 1 05-19-2009 02:19 PM
    CLK55 ESP Light and Car Stalls cali55 General AMG 5 01-23-2009 09:28 PM
    How do i get my car into Dyno mode? (no ESP/ABS/ etc.) timmynabenz C209/A209 CLK-Class 1 09-12-2008 05:32 AM
    ESP Failed - How should i fix it qhk333 C209/A209 CLK-Class 3 11-29-2007 07:00 AM
    Esp Shuts Car Down@ 80mph Need Help meen 55 W210 E50 AMG, E55 AMG 2 05-28-2007 01:29 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome