My first accident - Page 3 - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #21 of 36 (permalink) Old 12-05-2004, 03:44 PM Thread Starter
BenzWorld Elite
 
tiggerfink's Avatar
 
Date registered: May 2004
Vehicle: 2004 SL500 2002 SLK320
Location: TN USA
Posts: 1,672
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
RE: My first accident

In my case it is not State Farm's fault. I went to the body shop that my local Mercedes dealer recommended that did a bad job repairing my car.

Well, the new body shop gave me a call and I did not know to laugh or cry. The new body shop replaced everything that the original body did. All the parts that the bad body put on my car rusted so bad that some of the parts just fell apart. Also my rear tail lights got replace because the bad body shop made the holes bigger to screw in the tail lights. Basicly the bad body shop fudged so badly just to install the parts.

I was happy when the new body shop informed me that they got approval to repaint my whole car except for my roof.

2002 SLK320
2004 SL500
tiggerfink is offline  
Sponsored Links
Advertisement
 
post #22 of 36 (permalink) Old 12-05-2004, 10:51 PM
BenzWorld Junior Member
 
280ce's Avatar
 
Date registered: Nov 2004
Vehicle: 1980 MB280ce
Location: US N.J.
Posts: 46
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: My first accident

Well, Sorry for your accident. At least you didnt get rear ended while you were in the middle of your DRIVERS TEST........I was driving a Mercury mystique....got rear ended by a gmc denali or something. Woman on a cell phone...repairs were over 3,000 ,first words out of her mouth were "PLEASE DONT CALL THE COPS ILL DO ANYTHING DONT CALL THE COPS"....We called the cops. I got my license..
280ce is offline  
post #23 of 36 (permalink) Old 12-23-2004, 11:36 PM Thread Starter
BenzWorld Elite
 
tiggerfink's Avatar
 
Date registered: May 2004
Vehicle: 2004 SL500 2002 SLK320
Location: TN USA
Posts: 1,672
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
RE: My first accident

Here are some pics of my car neckad. The new body shop replaced all the stuff that the first body did. Check out the rust on some of the parts that had to be replace.
Attached Images
                         

2002 SLK320
2004 SL500
tiggerfink is offline  
post #24 of 36 (permalink) Old 01-07-2005, 04:53 PM
BenzWorld Elite
 
SILVER ARROW's Avatar
 
Date registered: Oct 2003
Vehicle: Mercedes SL R129
Location: Beirut, Lebanon
Posts: 1,293
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via MSN to SILVER ARROW
RE: My first accident

First, glad you're OK.
Second, thanks for the interesting pics.

SL SILVER ARROW WITH PANORAMIC HARDTOP, XENON, AMG FULL KIT, PARKTONIC SENSORS ... EVERY AVAILABLE OPTION!!!


<img src="http://www.benzworld.org/gallery/pics/104312611950642005120548PM.jpg" border=0>
SILVER ARROW is offline  
post #25 of 36 (permalink) Old 01-10-2005, 11:34 AM
BenzWorld Member
 
E Wagon's Avatar
 
Date registered: Jul 2004
Vehicle: 1999 E320 Wagon
Location: central Virgina
Posts: 367
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: My first accident

Wow! And this has been done twice? Hope your car is actually returned to factory spec after all this.

I going to see my baby at the doctor later this week. Not quite as bad as yours.
E Wagon is offline  
post #26 of 36 (permalink) Old 01-10-2005, 09:14 PM Thread Starter
BenzWorld Elite
 
tiggerfink's Avatar
 
Date registered: May 2004
Vehicle: 2004 SL500 2002 SLK320
Location: TN USA
Posts: 1,672
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
RE: My first accident

Quote:
E Wagon - 1/10/2005 12:34 PM

Wow! And this has been done twice? Hope your car is actually returned to factory spec after all this.

I going to see my baby at the doctor later this week. Not quite as bad as yours.
Thanks E Wagon,

The body shop called me after x-mass and discovered some more things wrong with the car, like a missing engine heat shield and the GPS not working. The car has been painted from head to toe with new paint from Germany. But it needs about 3 months to cure. So I may see my car in February/March.

The new cost is about $14,000 and the first body shop that did the work will have to pay for the repairs. Thank god State Farm is handling the bill.

By the way, did you see some of the wields separating.

2002 SLK320
2004 SL500
tiggerfink is offline  
post #27 of 36 (permalink) Old 01-10-2005, 10:06 PM
BenzWorld Elite
 
MBeige's Avatar
 
Date registered: Jan 2004
Vehicle: W-1-2-3 Go!
Location: California
Posts: 16,104
Mentioned: 1 Post(s)
Quoted: 198 Post(s)
RE: My first accident

I do hope it will feel the same way once you drive it again. Sometimes you don't get used to it anymore it feels alienated. My best of luck to you, and those individuals rebuilding your car.

MBeige is offline  
post #28 of 36 (permalink) Old 01-13-2005, 10:44 AM
BenzWorld Member
 
E Wagon's Avatar
 
Date registered: Jul 2004
Vehicle: 1999 E320 Wagon
Location: central Virgina
Posts: 367
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
RE: My first accident

That's bad. I kinda assumed that the new shop had broken those welds to do the repairs.

BTW have you been provided a rental car all this time?

I just saw my car yesterday. The shop is going to have the insurance pay to replace the hood. But over all I was slightly relieved when talking to the shop manager. I think they will do a good job. I'm keeping an eye and ear on them.
E Wagon is offline  
post #29 of 36 (permalink) Old 01-19-2005, 09:02 PM Thread Starter
BenzWorld Elite
 
tiggerfink's Avatar
 
Date registered: May 2004
Vehicle: 2004 SL500 2002 SLK320
Location: TN USA
Posts: 1,672
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
RE: My first accident

Quote:
E Wagon - 1/13/2005 11:44 AM

That's bad. I kinda assumed that the new shop had broken those welds to do the repairs.

BTW have you been provided a rental car all this time?

I just saw my car yesterday. The shop is going to have the insurance pay to replace the hood. But over all I was slightly relieved when talking to the shop manager. I think they will do a good job. I'm keeping an eye and ear on them.
Actually, the welds were broken when they got in there. That other body shop is in big trouble. I have been driving a rental Monto Carlo.

I wonder when will I see my car? They found some more stuff wrong with it last week. The car was painted in december, so the paint will be cured.

2002 SLK320
2004 SL500
tiggerfink is offline  
post #30 of 36 (permalink) Old 11-25-2005, 12:36 AM Thread Starter
BenzWorld Elite
 
tiggerfink's Avatar
 
Date registered: May 2004
Vehicle: 2004 SL500 2002 SLK320
Location: TN USA
Posts: 1,672
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
RE: My first accident

I got my car back on 11/5/05. The dealer installed a new top with a new rear glass. Overall the Nashville body shop and dealer did a good job, but there are no excuses for missing trim prices, broken trim pieces, missing screws, bolts, fasters, and nuts. I had a lot of unwanted sounds and once I put in the missing screw, bolts, and fasteners my car became very quiet. My car is very quiet like before the accident and drives great at 110 MPH.

I just spent over $80 in missing screws, bolts, fasteners, and broken trim pieces. The insurance company will reimburse me.

2002 SLK320
2004 SL500
tiggerfink is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > MB Safety & Testimonials

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome