Rain-sensor problems - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 11-04-2002, 12:32 PM Thread Starter
JQ
BenzWorld Member
 
JQ's Avatar
 
Date registered: Aug 2002
Vehicle: E430T + 300SL (W107)
Location: Sweden
Posts: 346
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Rain-sensor problems

I have problems with my rain sensor, and it is driving me crazy.

When it has been raining for a while, the wiper goes into "on" mode, and will not stop, even if the rain is light or it even stops raining. Seems like it is related to the wiper blade, which leaves a film on the windscreen. If I clean the edge of the blade (which cleans the part of the windscreen where the sensor is located) with my fingernails, it starts to work properly, but only for a few sweeps.

Rain sensor worked properly for a few months when I bought the car (with which I assume was new blades) but its getting worse and worse. As it is now, at light rain, the only solution is to shut it off, and wipe manually. Very irritating!

Car is still under warranty but my dealer says they can not do anything except changing the blade. Wiper blades are however expensive. I only had the car for six months, and the wiper still cleans the screen perfect. Did anyone have similar experience with his rain sensor?

_________________
/ Joakim Quensel
2000 E430T & 1989 300SL
JQ is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 12-10-2002, 07:28 AM Thread Starter
JQ
BenzWorld Member
 
JQ's Avatar
 
Date registered: Aug 2002
Vehicle: E430T + 300SL (W107)
Location: Sweden
Posts: 346
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
I think I solved the problem!

I noticed that the problem got worse after having washed the car. I normally use the "full-program" which applies wax, and my theory is that this creates a film on the wind-screen which makes the rain-sensor not work properly. After cleaning the screen and the wiper-blade with glass-cleaning detergent, the rain-sensor works perfect!



_________________
/ Joakim Quensel
2000 E430T & 1989 300SL
JQ is offline  
post #3 of 6 (permalink) Old 12-10-2002, 05:57 PM
BenzWorld Elite
 
garyroseyu's Avatar
 
Date registered: Sep 2002
Vehicle: 14 E350
Location: Honolulu, Hawaii
Posts: 2,046
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Thanks for the heads up JQ. : )



<I><B>2005 E500 "AMG Sport" <FONT COLOR="SILVER">Brilliant Silver</FONT></B></I> <FONT SIZE=-7>
garyroseyu is offline  
post #4 of 6 (permalink) Old 01-10-2003, 09:08 PM
BenzWorld Junior Member
 
Date registered: Jan 2003
Posts: 20
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
You should replace your wiper blades apromimently every 6mo. Every 3 mo is sugested on ...


You should replace your wiper blades apromimently every 6mo. Every 3 mo is sugested on some brands of whiper blades. And last time i checked they cost uneder 30bucks.
accord dude is offline  
post #5 of 6 (permalink) Old 01-12-2003, 01:05 AM Thread Starter
JQ
BenzWorld Member
 
JQ's Avatar
 
Date registered: Aug 2002
Vehicle: E430T + 300SL (W107)
Location: Sweden
Posts: 346
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
3 months! Thats quite often! But if its only $30, its no big deal. Is that OEM Mercedes? I...

3 months! Thats quite often! But if its only $30, its no big deal. Is that OEM Mercedes? I thought they were much more expensive, I never check the price but the wipers for my 107 SL are $100 but they are on the other hand in stainless steel... But also for the W126 I previously owned I think they were at least $60.

_________________
/ Joakim Quensel
2000 E430T & 1989 300SL
JQ is offline  
post #6 of 6 (permalink) Old 01-12-2003, 10:39 AM
BenzWorld Junior Member
 
Date registered: Jan 2003
Posts: 20
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
At lest to me haveing oem wiper blades is not that important go to your local auto zone ...


At lest to me haveing oem wiper blades is not that important go to your local auto zone and get what ever hey have that is the right size for your car. You measure whiper blades in inchens and also in width like it will say say 28w or 28n w=wide n=narrow.
These are the blades i use 28" Anco Aeroadvantage wiper blades they cost at most 28 bucks and are all metal Anco seams to make good blades i had a pair on the volvo that i neglected to change for about 2 yrs and they were still working fine.
accord dude is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome