Need a Good Laugh - Headlight wiper & pump diagnosis - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 10-13-2016, 09:56 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Oct 2013
Vehicle: 1995 Mercedes C36 AMG (RED)
Location: Tacoma, WA, USA
Posts: 20
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Garage
(Thread Starter)
Smile Need a Good Laugh - Headlight wiper & pump diagnosis

Sometimes you just have to laugh it off -

Vehicle: 1995 C36 AMG
With age the car has it's failures and gremlins. I like trying to DIY some of the work as a car of this vintage/value can't support stealership prices. Some of my Jeep threads offer a "What did you do to your XXX today?" - so I thought I'd sound off here to give you a laugh.

Recently, while servicing other problems under the hood, I managed to detach the windshield wiper fluid line from the RH headlight cleaning system. Eventually, this gave me a low wiper fluid warning light on the dash. Investigating, I filled the tank only to have the low fluid status return soon. Deeper investigations and I noticed no operation of the headlight system and leakage around the pumps. So, I disconnected the electrical and fluid lines. Cleaned the reservoir and re-secured everything. I reduced leak around reservoir, normal opn to windshield, but still one pump inop and headlight cleaning system inop. Flipping the electrical connections, the pump proved operational - so, it had to be the electrical. After 60mins tracing and peeling electrical lines around the reservoir and PITA wiring harnesses & molding - I found the pump also wired to the headlight system. So, I read the shop manual and found ..... wait for it....

The headlight cleaning system, wipers and pump only work with the wiper switch AND PARKING LIGHTS (min) ACTIVATED.

I hope this helps someone not waste time trying to fix something that isn't broken...
Noodles likes this.
CigarXO is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome