3.2L into 260E wiring questions - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 07-24-2016, 05:51 AM Thread Starter
BenzWorld Newbie
 
Date registered: Jul 2016
Vehicle: 1989 260E
Location: Granby, CT
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
3.2L into 260E wiring questions

Hello all,

A little background...

I have been on a race team with 5 other guys and we drive a 1989 260E. Recently, we decided on removing the 2.6L engine and installing a 3.2L engine from a late 1993 300CE for a bit more grunt down the straight-aways.

Here's my problem...the wiring has been a nightmare. I removed the ECM(two plug setup), E-Gas module and associated wiring harnesses from the 300CE and installed them into the 260. The E-Gas module is hooked up but there are a number of small plugs on the drivers side that I am unable to find a home for. The fuel system primes for 2 seconds when you flick the key and I get fuel pressure so i'm assuming the E-Gas computer is satisfied.

My problem is that I can't get spark or the injectors to fire. Everything seems to be satisfied from a voltage standpoint, but maybe not?? I have the wiring diagrams from this website which have been a tremendous help but i'm getting desperate as we have a race in only 2 weeks.

Questions I have...
1. What pin on the ECM (low number plug side) needs 12V?
2. What can be bypassed/grounded/tied to 12V to satisfy the ecm and allow the car to start?

I have unplugged the anti-theft computer, grounded pin 9 on the ECM an reconfigured plug "X26" on the 260 to accommodate the 300 setup.

The transmission is an automatic that's going to be shifted manually so most electronic transmission controls have been removed.

Any help would be great!
260Lemon is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 07-24-2016, 07:50 PM
Supporting Vendor
 
FCP Euro's Avatar
 
Date registered: Jul 2008
Posts: 697
Mentioned: 0 Post(s)
Quoted: 22 Post(s)
Welcome to the forum! If you haven't already done so, I recommend posting in the 124 forums for more visibility. The guys there are extremely knowledgeable. I'd love to come out and see the car, is the next event in CT? Best of luck getting things sorted.

--Kyle
FCP Euro is offline  
post #3 of 3 (permalink) Old 07-25-2016, 09:44 AM Thread Starter
BenzWorld Newbie
 
Date registered: Jul 2016
Vehicle: 1989 260E
Location: Granby, CT
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks for the intro Kyle!

I found the problem last night. There is a terminal block on the drivers side fender used as a 12V junction that was mislabeled from one of my team members. It was affectionately labeled (GROUND ON DRIVERS SIDE FENDER) instead of going to 12V. I tied this connection (9 gray wires and 1 red/pink wire) to 12V and the 3.2 fired to life!

For those who are doing engine swaps, here are some words from the wise...
1) TAKE YOUR TIME labeling ALL of the connections.
2) Save the donor car until yours is running 100%
3) DON'T cut any of the wires

This was my first Mercedes swap so everything was new to me. Does anyone know what some of the high failure components are? The MAF sensor is right above the exhaust manifold...maybe I should purchase a new one just in case?

Regards
260Lemon is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome