Airbag deployed for no reason 2013 C300 - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 08-11-2015, 07:45 PM Thread Starter
BenzWorld Newbie
 
Date registered: Aug 2015
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thumbs down Airbag deployed for no reason 2013 C300

I am wondering if anyone else has heard of the airbag deploying for no reason on the c300? I have a 2013 I just purchased 1 month ago as certified used and the airbag deployed in my face while driving.
jringer546 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 08-11-2015, 08:09 PM
Moderator
 
Date registered: Jul 2005
Vehicle: 90 300E, 99 ML430, 00 ML320, 05 E500 4matic Wagon
Location: WI
Posts: 19,064
Mentioned: 18 Post(s)
Quoted: 923 Post(s)
Lifetime Premium Member
Which airbag fired off?
Was the car purchased from a Mercedes Benz dealer as real MB CPO car?

If was not purchased from a genuine MB dealer then all bets are off. If it was from an MB dealer as CPO car then have it hauled back to them and start a serious discussion with them. Even it means they have to replace the car or refund the price due to having no confidence in the car's safety.

Lots of used car lots and dealers of other brands "certify" a used car, but it is not the same as an MB dealer selling a CPO car.

It is scary to have an airbag go off in accident let alone all by itself while driving. Were you driving the car it did it happen while it was parked?

Either way from whoever you bought it from it warrants some digging into. There are places to file the issue in both your state and at the Federal level.
I have been here a long time and this is the first time I have heard of a spontaneous airbag deployment with a car as new as a 2013.
Noodles is offline  
post #3 of 4 (permalink) Old 08-19-2015, 06:37 PM
DrX
BenzWorld Elite
 
DrX's Avatar
 
Date registered: Aug 2006
Vehicle: 2002 ML320, 2003 A160
Location: Brisbane, Australia
Posts: 3,460
Mentioned: 2 Post(s)
Quoted: 456 Post(s)
Pics or it didn't happen.
DrX is offline  
post #4 of 4 (permalink) Old 08-19-2015, 07:49 PM
Moderator
 
Date registered: Jul 2005
Vehicle: 90 300E, 99 ML430, 00 ML320, 05 E500 4matic Wagon
Location: WI
Posts: 19,064
Mentioned: 18 Post(s)
Quoted: 923 Post(s)
Lifetime Premium Member
My gut tells me it is just a drive by post. He has not logged in or even been back to the forums since that first post.
cmitch likes this.
Noodles is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome