MB SDconnect C4 work on 2005 W203 coupe - 2010 W221 S500 - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-05-2015, 07:48 PM Thread Starter
Date registered: Apr 2015
Vehicle: 2002 E320 sedan
Location: USA
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
MB SDconnect C4 work on 2005 W203 coupe - 2010 W221 S500

My cars 2005 W203 coupe - 2010 W221 S500

I recently bought a MB SDconnect C4 bundle with Dell D630 laptop hdd.

It's my first time use SDconnect, so I would like to share my experience.

Arrived through the online site obd2express.co.uk- So far the support and the shipping has been very quickly - The function of the MUX (The C4) or the software is also working fine.

First thing - Get your Dell 630 ready before the package from China arrives I was waiting a week for my D630 and power supply.

Coming from a IT electrical engineering background first thing I do on arrival is take it apart - Looks fairly well made. No obvious defects -

On to the function - I plugged it into the OBD2 - Boots software start wifi etc. looks good. The units from China all seem to have no batteries However the battery holder is present within the unit (6 x AA)
Checking with the seller from China I'm told DO NOT use batteries it will damage the MUX - So on use I get a insert battery message after some minutes does not seem to be an issue.

The MUX and software on the Dell D630 uses a cat 5 cable out of the box - No attempts to use the built in wifi yet.

The supplied HD has DAS with developer keys all setup - Also Xentry however the Xentry login complains about a missing key - Chinese seller is going to resolve I'm told shortly. Both my cars are DAS anyway so I'm not so concerned. Vedimo and Xentry can wait till my W222 upgrade

The W221 on DAS plugin and quick test is very interesting *lots* of systems on a fully loaded w221. All past faults list.

Seller's website related video presentations that can help first-time users.
cherrychen is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome