Surging 400E - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 06-17-2015, 01:06 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Apr 2015
Vehicle: '93 400E/S500
Location: Los Angeles
Posts: 17
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
(Thread Starter)
Surging 400E

I bought a 93 400E with a bad motor not long ago and ended up rebuilding a M119 from a S500 as a replacement. The swap was.....interesting. Not overly complicated as I only used the long block from the S class donor car and retained everything else from the original 420 motor. I have encountered a problem I don't know how to resolve. At idle the motor surges fairly rapidly by about 100 RPM's. At driving speeds from about 2000 RPM on up there is a major surging problem. I don't know how to get the fault codes as there is no code box like the one found on my E320. Also wondering if I missed something that needed to come with the S500 to the 400E engine bay. Anyone have any knowledge in this area that may help me correct this problem? Without a code reader I'm stumped. What makes the engine surge?
WHunterII is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome