SL Sat Nav receiving zero satellites - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-05-2015, 10:46 PM Thread Starter
BenzWorld Newbie
 
Date registered: Aug 2014
Vehicle: 2004 600SL
Location: England
Posts: 3
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
(Thread Starter)
Red face SL Sat Nav receiving zero satellites

I took my SL into the main dealer to have the Sat Nav fixed, it was showing Zero satellites received and the clock was also wrong.

They looked at it and returned the car to me with it in the same condition, saying that because I had a copy CD in the head unit, that was most probably the problem, even though it wasn't showing a "read error".

It was suggested that the Command head unit was faulty and should be replaced. This is very expensive, but I found one.

Just before paying a fortune for it, I decided to try the old computer trick. Switch it off and back on again - in this case I disconnected BOTH batteries for a few minutes.

Connected them back up, the clock reset itself and the Sat Nav can see 6 satellites again!

How come trained technicians can't do this? I nearly spent £1000 on a complete waste of time.

I hope this might help anyone with loss of Sat Nav in an SL or any other model.
g8aso is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 06-05-2015, 11:14 PM
BenzWorld Veteran
 
ollo's Avatar
 
Date registered: May 2009
Vehicle: S430 93K; E420 243K; 240D 242K
Location: Near Sublimity, Orygun
Posts: 625
Mentioned: 1 Post(s)
Quoted: 65 Post(s)
Garage
Quote:
Originally Posted by g8aso View Post
it was showing Zero satellites received and the clock was also wrong.... Switch it off and back on again -
Connected them back up, the clock reset itself and the Sat Nav can see 6 satellites again! How come trained technicians can't do this?
So true. Exact same scenario with our S class a few years ago. This also fixes things when Command tells you there is no CD player. Don
ollo is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome