TCU - can they be re-programmed ? - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 04-29-2015, 02:06 PM Thread Starter
BenzWorld Member
 
halman2228's Avatar
 
Date registered: Jul 2004
Vehicle: A bunch o of 'em - see signautre
Location: Houston
Posts: 223
Mentioned: 0 Post(s)
Quoted: 12 Post(s)
(Thread Starter)
TCU - can they be re-programmed ?

Can a TCU be re-programmed to a different car/VIN that uses the same TCU part #?

I'm getting conflicting answers - my indy with STAR says no...

TCU part # 030-545-20-32...

Definitive answer(s) appreciated,

Kevin

"Dangerous with a wrench and not smart enough to know it"

1984 Euro 500SL, 1984 280SEL (Euro)
1977 280SE, 1990 560SEL
1978 450SEL 6.9
1988 300CE (son at school)
1981 280SL, 1967 230SL
'86 560SEC, '04 S500 (SWfMBO's DD)
'95 C36
'01 CL55 Intergalactic cruiser
halman2228 is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 04-29-2015, 05:12 PM
BenzWorld Elite
 
Kajtek1's Avatar
 
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,783
Mentioned: 9 Post(s)
Quoted: 1124 Post(s)
Definite answer is
Not in USA legally.
Done every day in different countries.

Kajtek1 is online now  
post #3 of 11 (permalink) Old 04-30-2015, 11:07 AM Thread Starter
BenzWorld Member
 
halman2228's Avatar
 
Date registered: Jul 2004
Vehicle: A bunch o of 'em - see signautre
Location: Houston
Posts: 223
Mentioned: 0 Post(s)
Quoted: 12 Post(s)
(Thread Starter)
What makes it illegal?

...and can you point me in the direction of one of those hardened criminals that can reprogram a used TCU from a different car to mine?

Regards,
Kevin

"Dangerous with a wrench and not smart enough to know it"

1984 Euro 500SL, 1984 280SEL (Euro)
1977 280SE, 1990 560SEL
1978 450SEL 6.9
1988 300CE (son at school)
1981 280SL, 1967 230SL
'86 560SEC, '04 S500 (SWfMBO's DD)
'95 C36
'01 CL55 Intergalactic cruiser
halman2228 is offline  
post #4 of 11 (permalink) Old 04-30-2015, 12:39 PM
BenzWorld Elite
 
Kajtek1's Avatar
 
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,783
Mentioned: 9 Post(s)
Quoted: 1124 Post(s)
System makes it illegal, just like it is illegal to drive diesel wagons in this country.
Or 60 mpg diesel sedans.
There are people who could PM you with contact by now on the forum.
I know licensed shops in my native Poland that do such jobs on daily bases.
I did not ask if they have MB approval

Kajtek1 is online now  
post #5 of 11 (permalink) Old 04-30-2015, 01:09 PM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,176
Mentioned: 3 Post(s)
Quoted: 291 Post(s)
Which model and year is the car?

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline  
post #6 of 11 (permalink) Old 04-30-2015, 02:44 PM Thread Starter
BenzWorld Member
 
halman2228's Avatar
 
Date registered: Jul 2004
Vehicle: A bunch o of 'em - see signautre
Location: Houston
Posts: 223
Mentioned: 0 Post(s)
Quoted: 12 Post(s)
(Thread Starter)
I was hoping you'd chime in Eric...

My car = 2001 CL55 AMG (normally aspirated); Part # SIEMENS 5WP2, MB # A0305452032 EGS52

Donor car = C320 AMG year not specified; Part # SIEMENS 5WP2, MB # A0305452032 EGS52

Seller also noted these vehicles use it: SLK320 SLK430 KOMPRESSOR

Thanks for weighing in,
Kevin

"Dangerous with a wrench and not smart enough to know it"

1984 Euro 500SL, 1984 280SEL (Euro)
1977 280SE, 1990 560SEL
1978 450SEL 6.9
1988 300CE (son at school)
1981 280SL, 1967 230SL
'86 560SEC, '04 S500 (SWfMBO's DD)
'95 C36
'01 CL55 Intergalactic cruiser
halman2228 is offline  
post #7 of 11 (permalink) Old 04-30-2015, 10:05 PM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,176
Mentioned: 3 Post(s)
Quoted: 291 Post(s)
Quote:
Originally Posted by halman2228 View Post
My car = 2001 CL55 AMG (normally aspirated); Part # SIEMENS 5WP2, MB # A0305452032 EGS52

Donor car = C320 AMG year not specified; Part # SIEMENS 5WP2, MB # A0305452032 EGS52

Seller also noted these vehicles use it: SLK320 SLK430 KOMPRESSOR

Thanks for weighing in,
Kevin
It should work ok with your car PROVIDED it is not VIN coded and to be honest I am not sure which year they started the VIN coding. Perhaps someone else may know the answer to this.

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline  
post #8 of 11 (permalink) Old 05-04-2015, 07:40 AM Thread Starter
BenzWorld Member
 
halman2228's Avatar
 
Date registered: Jul 2004
Vehicle: A bunch o of 'em - see signautre
Location: Houston
Posts: 223
Mentioned: 0 Post(s)
Quoted: 12 Post(s)
(Thread Starter)
Thanks Eric; Might be the EIS ?

Still don't know who locally might be able to do the programming if it IS possible - I'm thinking the TCU is VIN coded though.

Anyway, I had my TCU repaired and now I can start the CL ONE TIME. No further starter action until I do a hard reboot (disconnect battery, wait a few minutes, reconnect).

Does this sound like an EIS problem ?

Note that I only have one key at the moment - ironically, I have a new spare waiting for me at the dealer... picture me telling the Service Writer that the tech needs to go into the trunk and do a hard reboot every time he turns the car off... right.

Input welcomed,
Kevin

"Dangerous with a wrench and not smart enough to know it"

1984 Euro 500SL, 1984 280SEL (Euro)
1977 280SE, 1990 560SEL
1978 450SEL 6.9
1988 300CE (son at school)
1981 280SL, 1967 230SL
'86 560SEC, '04 S500 (SWfMBO's DD)
'95 C36
'01 CL55 Intergalactic cruiser
halman2228 is offline  
post #9 of 11 (permalink) Old 05-04-2015, 08:08 AM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,176
Mentioned: 3 Post(s)
Quoted: 291 Post(s)
TCU not recognised?

Quote:
Originally Posted by halman2228 View Post
Still don't know who locally might be able to do the programming if it IS possible - I'm thinking the TCU is VIN coded though.

Anyway, I had my TCU repaired and now I can start the CL ONE TIME. No further starter action until I do a hard reboot (disconnect battery, wait a few minutes, reconnect).

Does this sound like an EIS problem ?

Note that I only have one key at the moment - ironically, I have a new spare waiting for me at the dealer... picture me telling the Service Writer that the tech needs to go into the trunk and do a hard reboot every time he turns the car off... right.

Input welcomed,
Kevin
If it allows one engine start and then the engine stops and will not restart it means the Drive authorizations system does not recognise one of the control units.

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline  
post #10 of 11 (permalink) Old 05-05-2015, 08:06 AM Thread Starter
BenzWorld Member
 
halman2228's Avatar
 
Date registered: Jul 2004
Vehicle: A bunch o of 'em - see signautre
Location: Houston
Posts: 223
Mentioned: 0 Post(s)
Quoted: 12 Post(s)
(Thread Starter)
Runs fine after 1st Start...

... not in limp mode or any other errors showing up. It does not shut itself off...

When you turn it off though, it will not restart until you hard reboot. After hard reboot, you again are able to start and run fine ONCE.

EIS or the immobilizer (which I believe is the ESL) ?

Kevin

"Dangerous with a wrench and not smart enough to know it"

1984 Euro 500SL, 1984 280SEL (Euro)
1977 280SE, 1990 560SEL
1978 450SEL 6.9
1988 300CE (son at school)
1981 280SL, 1967 230SL
'86 560SEC, '04 S500 (SWfMBO's DD)
'95 C36
'01 CL55 Intergalactic cruiser
halman2228 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome