worn springs change camber and create tire noise?? - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 07-14-2014, 11:33 AM Thread Starter
BenzWorld Member
Date registered: Jul 2007
Vehicle: '12 E550 Cabriolet, steel grey, P2; '07 R320 CDI, P1, Barolo red
Location: Suburban Philadelphia
Posts: 114
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
worn springs change camber and create tire noise??

Hi, out of left field, but I am at wits end. We have a 2007 R 320 with OEM rims. Left front wheel has hummed like a truck tire for as long as I can remember. Dealer has "tried everything" over the years with no success. Even have new tires and nothing. Could this be a camber issue?? Never been in an accident, but who knows what pot holes wife has gone over in 7 years. Any thoughts are greatly appreciated.

Also in the last alignment they noticed ride height is off, suggesting one or both springs are worn which could change camber, correct? Thoughts? Is it worth replacing springs or just deal with noise? I guess I am worried about cascading issues (bushings, bearings, etc), uneven tire wear, etc.

mpgurin is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome