Immobiliser problem - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 07-01-2014, 07:02 PM Thread Starter
BenzWorld Newbie
Date registered: Jun 2014
Vehicle: SL 500 1992
Location: Thailand
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Immobiliser problem


I have a 1990 SL300 , I have just changed the battery as the car was standing for a few months.
Initially the car started but the hazard lights were all flashing quickly, after stopping the car and trying to re-start the lights are still flashing and it cranks over but does not start as though the immobilizer is activated?
I have tried disconnecting and re-connecting the battery but the hazards start to flash immediately and will not start.
I don't have a remote for the alarm I have been locking the door manually with the blade key.
I live in Thailand so parts and expertise are a bit thin on the ground !

Any ideas Thanks Nick
Nickwad is offline  
Sponsored Links
post #2 of 2 (permalink) Old 07-02-2014, 01:04 AM
Outstanding Contributor
television's Avatar
Date registered: Sep 2005
Vehicle: 216 with everything. 2002 SL500 with everything. 2009 SL500 with everything.
Location: South coast .England
Posts: 6,442
Mentioned: 1 Post(s)
Quoted: 113 Post(s)
I would say that the batteries in the alarm siren have failed, disconnect the siren and you could be back to normal.


"I thought my vasectomy would keep my wife from getting pregnant but apparently it just changes the color of the baby."
television is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome