CEL on sporadically in C320 Wagon - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 06-29-2014, 09:12 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Jun 2014
Vehicle: 2004 C320 4MATIC WAGON
Location: VESTAL, NY
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
CEL on sporadically in C320 Wagon

Hello everyone,

I drive a 2004 C320 wagon that lately has been driving me!

Seven days ago, I failed to tighten the fuel cap on after filling up. I got the customary warning light on my dash with a flashing of the fuel gauge light. Once I realized what the problem was, I tightened the cap and all was well.

Three days later, however, the CEL came on briefly. I tightened the cap and it went off. Three days after that, however, the big trouble happened. After filling the tank, the CEL came on again, with a sputtering of the engine that wouldn't turn over. I had it towed the 150 miles from home, even though it ran normally after a few minutes. It is running normally now, with no CEL on (which is why auto zone can't give me a code).

Any insight into the problem?
Missykins is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 06-29-2014, 12:43 PM
Moderator
 
Date registered: Jul 2005
Vehicle: 99 ML430, 00 ML320, 05 E500 4matic Wagon
Location: WI
Posts: 20,076
Mentioned: 22 Post(s)
Quoted: 1140 Post(s)
Lifetime Premium Member
There are stored codes, pending codes and current codes. I am surprised it did not show up in the stored codes so there is a reference of what might have happened.
Noodles is offline  
post #3 of 6 (permalink) Old 06-29-2014, 03:01 PM
BenzWorld Elite
 
Kajtek1's Avatar
 
Date registered: Dec 2005
Vehicle: E320/E250 Bluetec R129 SL500 - $1300 car ........ Ford F350 6.7l
Location: V E G A S
Posts: 32,674
Mentioned: 10 Post(s)
Quoted: 1340 Post(s)
Spending $29 on scanner could prevent you from 150 miles towing.

Kajtek1 is online now  
 
post #4 of 6 (permalink) Old 07-09-2014, 08:44 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Jun 2014
Vehicle: 2004 C320 4MATIC WAGON
Location: VESTAL, NY
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Turned out to be a crankshaft position sensor, which is quite common from what I understand.
Missykins is offline  
post #5 of 6 (permalink) Old 07-09-2014, 09:19 PM
BenzWorld Elite
 
Check Codes's Avatar
 
Date registered: Mar 2005
Vehicle: '01-E320 & 02-ST2
Location: John 15:18-19
Posts: 31,634
Mentioned: 0 Post(s)
Quoted: 35 Post(s)
Quote:
Originally Posted by Missykins View Post
Turned out to be a crankshaft position sensor, which is quite common from what I understand.
I am coming late to the party, but that would have been my guess.

You were fooled/distracted by the earlier fuel cap issue.

If you want to stay a little more on top of things with your car, the MS309 scanner is about $20 on Amazon, it's a great little tool.

Good luck.

Socialism is a philosophy of failure, the creed of ignorance, and the gospel of envy; its inherent virtue is the equal sharing of misery. (Winston Churchill)
Check Codes is offline  
post #6 of 6 (permalink) Old 07-10-2014, 05:14 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Jun 2014
Vehicle: 2004 C320 4MATIC WAGON
Location: VESTAL, NY
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
You're right! Thanks for the information.
Missykins is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome