'89 300SE Problems (Half fixed) - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-03-2014, 01:07 AM Thread Starter
BenzWorld Junior Member
Date registered: May 2014
Vehicle: 83 380sec
Location: Australia
Posts: 44
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
(Thread Starter)
'89 300SE Problems (Half fixed)

Hey all,

So, My merc has recently been running a bit how ya going.
When moving from a stopped position it seems to shudder and come close to stalling.
Eventually, the car wouldn't start.. at all.. Keep in mind this was after it just died at the shops (conveniently into a park, so no one was the wiser to know what just happened).
I pushed it to the road and put some fuel in it, thinking it ran out.. It started, moved a few meters around the corner, and died again.
I then went home and slept it off, came back in the morning, started it up, took off, it shuddered at the main intersection (first intersection of slowing down) so i booted it, and got home safely.
A few drives after were much the same, no dieing, but alot of shuddering, and the feeling of about to stall.
SO... Eventually, it got to the point where the car would fire, and die, and then just not start after that.
I checked the spark plugs, and air cleaner, and they were clean and fine.
I checked the fuses and they were fine also. I checked the fuel pump and it was silent when trying to fire.
I purchased a fuel pump relay today from a wrecking yard, and it looks a bit odd...

Generally the relay is something like this
* * * *
* * * * * *

The prongs, Should be able to understand.. My car only had room for three on the top, so one was already snapped off... looks snapped anyway (Wreckers, right?)

So i've got something that resembles this

* * *
* * * * * *

Plugged it in, she fires up, We're talkin'

I take it for a cruise, It shudders a bit and i decide to boot it, and it goes fine. It starts to head up a hill, and all of a sudden starts jerking back and forth... Weird, i back off.
I then drive around the back streets, and all is fine, no worries at all.
I get to an intersection and wait for a while, and take off, it shudders a bit, but not so bad.
I take it around the block further and start going down a hill, i test it again, i floor it, and its fine, it starts to go up a hill.. the violent jerking back and forth starts again. I back off, and stop at the lights, which are on a steep incline, On green, it takes off with alot of shuddering, almost barely..

I've come to the conclusion that it might have something to do with being on an incline..? or maybe a decline since it shuddered a bit after that too.

End of the day though, the fuel pump relay worked wonders, started the car right up.. Now i have to figure out why it keeps shuddering and feeling like its about to die?

Any help would be greatly appreciated !
Thanks for reading,

weirdo is offline  
Sponsored Links
post #2 of 3 (permalink) Old 06-03-2014, 05:35 AM Thread Starter
BenzWorld Junior Member
Date registered: May 2014
Vehicle: 83 380sec
Location: Australia
Posts: 44
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
(Thread Starter)
Chucked a second relay in, Problem fixed!
weirdo is offline  
post #3 of 3 (permalink) Old 06-03-2014, 06:29 AM
BenzWorld Elite
flyboyike's Avatar
Date registered: May 2003
Vehicle: 2012 Focus SE
Location: Ormond Beach, FL
Posts: 7,697
Mentioned: 1 Post(s)
Quoted: 67 Post(s)
Good news. I'd swap out the fuel filter just in case also, especially if you don't know when that was done last, if ever.

Felicita e un bicchiere di vino con un panino.
flyboyike is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome